dev-ruby/rrdtool-bindings: DEPEND on net-analyzer/rrdtool
authorJeroen Roovers <jer@gentoo.org>
Sat, 14 Sep 2019 08:35:42 +0000 (10:35 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sat, 14 Sep 2019 08:40:39 +0000 (10:40 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Bug: https://bugs.gentoo.org/690318
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild
dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.0.ebuild [deleted file]
dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1-r1.ebuild
dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1.ebuild [deleted file]
dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.2.ebuild

index 50bf714fd428c0904a92831105160cc82ed95726..20f293c3ab7f1b2593cad9985a0282aae09d0fe1 100644 (file)
@@ -29,6 +29,7 @@ RDEPEND="
        ~net-analyzer/rrdtool-${PV}[graph=]
 "
 DEPEND="
+       ${RDEPEND}
        test? ( ~net-analyzer/rrdtool-${PV}[graph] )
 "
 
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.0.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.0.ebuild
deleted file mode 100644 (file)
index 1f8d1af..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-RUBY_FAKEGEM_TASK_DOC=""
-inherit ruby-ng
-
-MY_P=${P/-bindings}
-MY_P=${MY_P/_/-}
-
-DESCRIPTION="Ruby bindings for rrdtool"
-HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
-SRC_URI="${HOMEPAGE}pub/${MY_P}.tar.gz"
-RUBY_S="$MY_P"/bindings/ruby
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="graph test"
-REQUIRED_USE="test? ( graph )"
-
-# Block on older versions of rrdtool that install the bindings themselves.
-# requires rrd_xport which requires rrd_graph
-RDEPEND="
-       ~net-analyzer/rrdtool-${PV}[graph=]
-"
-DEPEND="
-       test? ( ~net-analyzer/rrdtool-${PV}[graph] )
-"
-
-RUBY_PATCHES=(
-       "${FILESDIR}"/${PN}-1.4.8-graph-ruby.patch
-)
-
-each_ruby_configure() {
-       rm ../../src/rrd_config.h || die
-       touch ../../src/rrd_config.h || die
-
-       ${RUBY} extconf.rb \
-               --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH -UHAVE_RRD_GRAPH)" || die
-}
-
-each_ruby_compile() {
-       emake V=1 ABS_TOP_SRCDIR="${PWD}/../.."
-}
-
-each_ruby_test() {
-       if use graph; then
-               ${RUBY} -I. test.rb || die
-       fi
-}
-
-all_ruby_install() {
-       dodoc CHANGES README
-}
-
-each_ruby_install() {
-       DESTDIR=${D} emake install
-}
index 113be286f9b9d948aa99dec5753e485c690ed125..aa652bbfc94ce3e1cbbedf03c4fc81aadc000d3c 100644 (file)
@@ -26,6 +26,7 @@ RDEPEND="
        ~net-analyzer/rrdtool-${PV}[graph=]
 "
 DEPEND="
+       ${RDEPEND}
        test? ( ~net-analyzer/rrdtool-${PV}[graph] )
 "
 
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1.ebuild
deleted file mode 100644 (file)
index 4ed4275..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-RUBY_FAKEGEM_TASK_DOC=""
-inherit ruby-ng
-
-MY_P=${P/-bindings}
-MY_P=${MY_P/_/-}
-
-DESCRIPTION="Ruby bindings for rrdtool"
-HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
-SRC_URI="${HOMEPAGE}pub/${MY_P}.tar.gz"
-RUBY_S="$MY_P"/bindings/ruby
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="graph test"
-REQUIRED_USE="test? ( graph )"
-
-# Block on older versions of rrdtool that install the bindings themselves.
-# requires rrd_xport which requires rrd_graph
-RDEPEND="
-       ~net-analyzer/rrdtool-${PV}[graph=]
-"
-DEPEND="
-       test? ( ~net-analyzer/rrdtool-${PV}[graph] )
-"
-RUBY_PATCHES=(
-       "${FILESDIR}"/${PN}-1.4.8-graph-ruby.patch
-)
-
-each_ruby_configure() {
-       rm ../../src/rrd_config.h || die
-       touch ../../src/rrd_config.h || die
-
-       ${RUBY} extconf.rb \
-               --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH -UHAVE_RRD_GRAPH)" || die
-}
-
-each_ruby_compile() {
-       emake V=1 ABS_TOP_SRCDIR="${PWD}/../.."
-}
-
-each_ruby_test() {
-       if use graph; then
-               ${RUBY} -I. test.rb || die
-       fi
-}
-
-all_ruby_install() {
-       dodoc CHANGES README
-}
-
-each_ruby_install() {
-       DESTDIR=${D} emake install
-}
index 113be286f9b9d948aa99dec5753e485c690ed125..aa652bbfc94ce3e1cbbedf03c4fc81aadc000d3c 100644 (file)
@@ -26,6 +26,7 @@ RDEPEND="
        ~net-analyzer/rrdtool-${PV}[graph=]
 "
 DEPEND="
+       ${RDEPEND}
        test? ( ~net-analyzer/rrdtool-${PV}[graph] )
 "