dev-ada/langkit: fix dependency and try to respect -j1
authorTupone Alfredo <tupone@gentoo.org>
Sun, 7 Jul 2019 19:57:09 +0000 (21:57 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Sun, 7 Jul 2019 19:57:09 +0000 (21:57 +0200)
Bug: https://bugs.gentoo.org/677816
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-ada/langkit/langkit-2018.ebuild
dev-ada/langkit/langkit-2019.ebuild

index 6fe74a78bc9a88b40bb3fb7460726f462c6eeec5..348ef449845aa5e876967f871ba6d14728f2b742 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit python-single-r1
+inherit python-single-r1 multiprocessing
 
 MYP=${PN}-gpl-${PV}
 
@@ -24,6 +24,7 @@ DEPEND="${PYTHON_DEPS}
        dev-ada/gnatcoll-bindings[iconv,shared]
        dev-python/mako
        dev-python/pyyaml
+       <dev-python/pyyaml-5
        dev-python/enum34
        dev-python/funcy
        dev-python/docutils
@@ -35,7 +36,7 @@ S="${WORKDIR}"/${MYP}-src
 PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
 
 src_test() {
-       testsuite/testsuite.py --show-error-output | tee testsuite.log
+       testsuite/testsuite.py -j $(makeopts_jobs) --show-error-output | tee testsuite.log
        grep -q FAILED testsuite.log && die "Test failed"
 }
 
index 1cc699ee20a637afeb54893b8e2f178e0bb19f12..72bcd4d3adbb3d4cbd5774e8d13c518dcfccf5ea 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit python-single-r1
+inherit python-single-r1 multiprocessing
 
 MYP=${P}-20190510-19B8C
 
@@ -36,7 +36,7 @@ S="${WORKDIR}"/${MYP}-src
 PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
 
 src_test() {
-       testsuite/testsuite.py --show-error-output | tee testsuite.log
+       testsuite/testsuite.py -j $(makeopts_jobs) --show-error-output | tee testsuite.log
        grep -q FAILED testsuite.log && die "Test failed"
 }