net-misc/networkmanager: Fixing kernel config check
authorRodrigo Saboya <saboya@gmail.com>
Wed, 31 Jul 2019 14:35:52 +0000 (11:35 -0300)
committerMatt Turner <mattst88@gentoo.org>
Mon, 21 Oct 2019 19:39:40 +0000 (12:39 -0700)
CONFIG_NF_NAT_IPV4 and CONFIG_NF_NAT_IPV6 were merged into CONFIG_NF_NAT on:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=3bf195ae6037e310d693ff3313401cfaf1261b71

CONFIG_NF_NAT_MASQUERADE_IPV4 and CONFIG_NF_NAT_MASQUERADE_IPV6 were merged into CONFIG_NF_NAT_MASQUERADE on:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=d1aca8ab3104aa7131f5ab144c6f586b54df084b

Closes: https://bugs.gentoo.org/691140
Closes: https://github.com/gentoo/gentoo/pull/12559
Signed-off-by: Rodrigo Saboya <saboya@gmail.com>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
net-misc/networkmanager/networkmanager-1.18.2.ebuild
net-misc/networkmanager/networkmanager-1.18.4-r1.ebuild

index 4342ec029baba4082f9da2e96fd5082a40ea4436..2c4f15a72ad4144d5e6eccacc858c52b8925ac7f 100644 (file)
@@ -139,7 +139,11 @@ pkg_pretend() {
 
 pkg_setup() {
        if use connection-sharing; then
-               CONFIG_CHECK="~NF_NAT ~NF_NAT_MASQUERADE"
+               if kernel_is lt 5 1; then
+                       CONFIG_CHECK="~NF_NAT_IPV4 ~NF_NAT_MASQUERADE_IPV4"
+               else
+                       CONFIG_CHECK="~NF_NAT ~NF_NAT_MASQUERADE"
+               fi
                linux-info_pkg_setup
        fi
        if use introspection || use test; then
index 6698561d3d6b83be6b9995f5928d1e6ae38eb72a..349e1bbb84c98aa086a03becd6d487298516efe1 100644 (file)
@@ -143,7 +143,11 @@ pkg_pretend() {
 
 pkg_setup() {
        if use connection-sharing; then
-               CONFIG_CHECK="~NF_NAT ~NF_NAT_MASQUERADE"
+               if kernel_is lt 5 1; then
+                       CONFIG_CHECK="~NF_NAT_IPV4 ~NF_NAT_MASQUERADE_IPV4"
+               else
+                       CONFIG_CHECK="~NF_NAT ~NF_NAT_MASQUERADE"
+               fi
                linux-info_pkg_setup
        fi
        if use introspection || use test; then