dev-python/utidylib: 0.3 bump; python3, EAPI 6, fix HOMEPAGE
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>
Sat, 8 Oct 2016 13:05:20 +0000 (15:05 +0200)
committerDavid Seifert <soap@gentoo.org>
Fri, 21 Oct 2016 21:38:36 +0000 (23:38 +0200)
New upstream.

Package-Manager: portage-2.3.0
Closes: https://github.com/gentoo/gentoo/pull/2513

Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/utidylib/Manifest
dev-python/utidylib/metadata.xml
dev-python/utidylib/utidylib-0.3.ebuild [new file with mode: 0644]

index 5b63101a758c8aaf3856dd707c65b20f48bfd2d0..05feb4dbff04b17f5cfb174fd7aa1099c5193195 100644 (file)
@@ -1 +1,2 @@
 DIST uTidylib-0.2.zip 17575 SHA256 0385b29b0e636fa1cc6eb86ecb5428cf399f9474c8f343af038afce59720a333 SHA512 02f6611f1c7dd42db96012f7067ada8ccd841532744a569492a2f1c0524a3f1777b8f997a716b9bb18f69f31cb922dc89328d0bd284830620a930a038b303893 WHIRLPOOL 7d1509c36dccf8d7bd22f82d5a6cd95e8b7e422fb6aeab49e7316aaa98e18f771d9c7140897086da61d03b0df5fb3d4291c0b49acfbf8a8633498a837fbc2c2d
+DIST uTidylib-0.3.tar.bz2 13809 SHA256 9f902713bf5d6b8254ca99dccc8729cbe833b1377cfcca67b466c661e5e3f57b SHA512 4503f2a6366e5110740b312df2300d62bb68e1e1032184e9b56dee75995309c76d4f8e5851c73e7c8e08cca7bba9c74436d8dfc0524f115f3abb2bdf5529cc35 WHIRLPOOL 3157558b2674e60ae231ba0ae38523a84659ad375ea2ca1b75e29e118c7cc67d7b66b91733ad68f2b6c3c93d72a0d209e36b576ce52bb33242e20810ec992ab2
index 726c2591debbe000756a9df7a77f58177bb529e0..2ab18a2e21e35f6ecf132f212d9b0d0edbeeb7ea 100644 (file)
@@ -1,11 +1,11 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-  <maintainer type="project">
-    <email>python@gentoo.org</email>
-    <name>Python</name>
-  </maintainer>
-  <upstream>
-    <remote-id type="sourceforge">utidylib</remote-id>
-  </upstream>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+               <name>Python</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">nijel/utidylib</remote-id>
+       </upstream>
 </pkgmetadata>
diff --git a/dev-python/utidylib/utidylib-0.3.ebuild b/dev-python/utidylib/utidylib-0.3.ebuild
new file mode 100644 (file)
index 0000000..fafb5b4
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MY_P="uTidylib-${PV}"
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="https://cihar.com/software/utidylib/"
+SRC_URI="http://dl.cihar.com/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+       app-text/htmltidy
+       dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"        # 1/11 tests fail
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+       if use doc; then
+               ${EPYTHON} setup.py build_sphinx || die
+       fi
+}
+
+python_test() {
+       py.test || die "testsuite failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( build/sphinx/html/. )
+       distutils-r1_python_install_all
+}