sys-apps/kmod: Bump to version 27
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 19 Feb 2020 09:47:28 +0000 (10:47 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 19 Feb 2020 09:47:28 +0000 (10:47 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/kmod/Manifest
sys-apps/kmod/kmod-27.ebuild [new file with mode: 0644]

index b0cb0a1e990d40b4e4a0fa773b52300d83438162..c32d51e47904ce19375d6f7062e69735b2e73509 100644 (file)
@@ -1,2 +1,3 @@
 DIST kmod-25.tar.xz 545416 BLAKE2B 2ad428f70630a1ef509be888a9ebc45f164695365f0f722f5e7793e96b60c035040b4d9a27f926361cea6d665310fc6cc5599ff4aefeda0fae8571c6510a25a7 SHA512 d579cd0cea24a06362a74927b7a3c777e9e01c990306e1032e4781cd441ffe435c70f2c2c4f6ae39eb1d857e622746411d5824d0c0d8bb79f91dc9fa51956252
 DIST kmod-26.tar.xz 552032 BLAKE2B 3e596d06b48599bf4919346475a036b058fb18a7b19d39953e24fa943b95fdbe34a29a5062f6b4fe3510e667ae873d3b9ae03b72350fa85ddbb40ca6a7730b34 SHA512 3ca276c6fc13c2dd2220ec528b8dc4ab4edee5d2b22e16b6f945c552e51f74342c01c33a53740e6af8c893d42bd4d6f629cd8fa6e15ef8bd8da30cb003ef0865
+DIST kmod-27.tar.xz 548924 BLAKE2B 9f12bf5792d4c867e28e0776c279369c063e84269212e3f699ae6e5e69b8b2b466b5033e43e17ac64d6101592edcf3c34881916afb6ae676b49dc8838dfe1396 SHA512 e0513094935333fca1fb4c3e3493b232507a579ab00a6457cc9ed3e928363d05aad80634fb65a8287a336bf9895194c7be8ddc41bb088a6c2cca44fc1bfbdb6c
diff --git a/sys-apps/kmod/kmod-27.ebuild b/sys-apps/kmod/kmod-27.ebuild
new file mode 100644 (file)
index 0000000..e0a5eee
--- /dev/null
@@ -0,0 +1,202 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools bash-completion-r1 multilib python-r1
+
+if [[ ${PV} == 9999* ]]; then
+       EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://www.kernel.org/pub/linux/utils/kernel/kmod/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+       #inherit libtool
+fi
+
+DESCRIPTION="library and tools for managing linux kernel modules"
+HOMEPAGE="https://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug doc libressl lzma pkcs7 python static-libs +tools zlib"
+
+# Upstream does not support running the test suite with custom configure flags.
+# I was also told that the test suite is intended for kmod developers.
+# So we have to restrict it.
+# See bug #408915.
+RESTRICT="test"
+
+# Block systemd below 217 for -static-nodes-indicate-that-creation-of-static-nodes-.patch
+RDEPEND="!sys-apps/module-init-tools
+       !sys-apps/modutils
+       !<sys-apps/openrc-0.13.8
+       !<sys-apps/systemd-216-r3
+       lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
+       python? ( ${PYTHON_DEPS} )
+       pkcs7? (
+               !libressl? ( >=dev-libs/openssl-1.1.0:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )
+       zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
+DEPEND="${RDEPEND}"
+BDEPEND="
+       doc? (
+               dev-util/gtk-doc
+               dev-util/gtk-doc-am
+       )
+       lzma? ( virtual/pkgconfig )
+       python? (
+               dev-python/cython[${PYTHON_USEDEP}]
+               virtual/pkgconfig
+               )
+       zlib? ( virtual/pkgconfig )
+"
+if [[ ${PV} == 9999* ]]; then
+       DEPEND="${DEPEND}
+               dev-libs/libxslt"
+fi
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DOCS="NEWS README TODO"
+
+src_prepare() {
+       default
+
+       if [[ ! -e configure ]] || use doc ; then
+               if use doc; then
+                       cp "${EROOT}"/usr/share/aclocal/gtk-doc.m4 m4 || die
+                       gtkdocize --copy --docdir libkmod/docs || die
+               else
+                       touch libkmod/docs/gtk-doc.make
+               fi
+               eautoreconf
+       else
+               elibtoolize
+       fi
+
+       # Restore possibility of running --enable-static wrt #472608
+       sed -i \
+               -e '/--enable-static is not supported by kmod/s:as_fn_error:echo:' \
+               configure || die
+}
+
+src_configure() {
+       local myeconfargs=(
+               --bindir="${EPREFIX}/bin"
+               --enable-shared
+               --with-bashcompletiondir="$(get_bashcompdir)"
+               --with-rootlibdir="${EPREFIX}/$(get_libdir)"
+               $(use_enable debug)
+               $(usex doc '--enable-gtk-doc' '')
+               $(use_enable static-libs static)
+               $(use_enable tools)
+               $(use_with lzma xz)
+               $(use_with pkcs7 openssl)
+               $(use_with zlib)
+       )
+
+       local ECONF_SOURCE="${S}"
+
+       kmod_configure() {
+               mkdir -p "${BUILD_DIR}" || die
+               run_in_build_dir econf "${myeconfargs[@]}" "$@"
+       }
+
+       BUILD_DIR="${WORKDIR}/build"
+       kmod_configure --disable-python
+
+       if use python; then
+               python_foreach_impl kmod_configure --enable-python
+       fi
+}
+
+src_compile() {
+       emake -C "${BUILD_DIR}"
+
+       if use python; then
+               local native_builddir=${BUILD_DIR}
+
+               python_compile() {
+                       emake -C "${BUILD_DIR}" -f Makefile -f - python \
+                               VPATH="${native_builddir}:${S}" \
+                               native_builddir="${native_builddir}" \
+                               libkmod_python_kmod_{kmod,list,module,_util}_la_LIBADD='$(PYTHON_LIBS) $(native_builddir)/libkmod/libkmod.la' \
+                               <<< 'python: $(pkgpyexec_LTLIBRARIES)'
+               }
+
+               python_foreach_impl python_compile
+       fi
+}
+
+src_install() {
+       emake -C "${BUILD_DIR}" DESTDIR="${D}" install
+       einstalldocs
+
+       if use python; then
+               local native_builddir=${BUILD_DIR}
+
+               python_install() {
+                       emake -C "${BUILD_DIR}" DESTDIR="${D}" \
+                               VPATH="${native_builddir}:${S}" \
+                               install-pkgpyexecLTLIBRARIES \
+                               install-dist_pkgpyexecPYTHON
+               }
+
+               python_foreach_impl python_install
+       fi
+
+       find "${ED}" -type f -name "*.la" -delete || die
+
+       if use tools; then
+               local cmd
+               for cmd in depmod insmod modprobe rmmod; do
+                       dosym ../bin/kmod /sbin/${cmd}
+               done
+
+               # These are also usable as normal user
+               for cmd in lsmod modinfo; do
+                       dosym kmod /bin/${cmd}
+               done
+       fi
+
+       cat <<-EOF > "${T}"/usb-load-ehci-first.conf
+       softdep uhci_hcd pre: ehci_hcd
+       softdep ohci_hcd pre: ehci_hcd
+       EOF
+
+       insinto /lib/modprobe.d
+       doins "${T}"/usb-load-ehci-first.conf #260139
+
+       newinitd "${FILESDIR}"/kmod-static-nodes-r1 kmod-static-nodes
+}
+
+pkg_postinst() {
+       if [[ -L ${EROOT}/etc/runlevels/boot/static-nodes ]]; then
+               ewarn "Removing old conflicting static-nodes init script from the boot runlevel"
+               rm -f "${EROOT}"/etc/runlevels/boot/static-nodes
+       fi
+
+       # Add kmod to the runlevel automatically if this is the first install of this package.
+       if [[ -z ${REPLACING_VERSIONS} ]]; then
+               if [[ ! -d ${EROOT}/etc/runlevels/sysinit ]]; then
+                       mkdir -p "${EROOT}"/etc/runlevels/sysinit
+               fi
+               if [[ -x ${EROOT}/etc/init.d/kmod-static-nodes ]]; then
+                       ln -s /etc/init.d/kmod-static-nodes "${EROOT}"/etc/runlevels/sysinit/kmod-static-nodes
+               fi
+       fi
+
+       if [[ -e ${EROOT}/etc/runlevels/sysinit ]]; then
+               if [[ ! -e ${EROOT}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
+                       ewarn
+                       ewarn "You need to add kmod-static-nodes to the sysinit runlevel for"
+                       ewarn "kernel modules to have required static nodes!"
+                       ewarn "Run this command:"
+                       ewarn "\trc-update add kmod-static-nodes sysinit"
+               fi
+       fi
+}