app-benchmarks/siege: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sat, 26 Jan 2019 20:19:17 +0000 (21:19 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 26 Jan 2019 20:19:17 +0000 (21:19 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
app-benchmarks/siege/Manifest
app-benchmarks/siege/siege-3.1.4.ebuild [deleted file]

index 0357b73a4e13639ed9c55a96ce22896e08d974c8..0594c1e22e39c45cf474ce48c241ca235ed24720 100644 (file)
@@ -1,2 +1 @@
-DIST siege-3.1.4.tar.gz 530149 BLAKE2B 3721387fa1ace745ce7748612849b84c07e84456bd903460930ab407cba1e24f493d4a251bacd3e509aafbc653e5d74e96509bf74f0a2a8066a0ec2b7ad2e9ee SHA512 8e8b4c1e9c20833f4c3538e8929e47d1c9113cd1faf395e5f07734fb7f4291061cb7554cf500a80d8b1b6be0d6f4c8194b054f632f35533837220702784ee068
 DIST siege-4.0.4.tar.gz 523102 BLAKE2B 2d69dd37fea7ff35e05b41d500d4efb5b4fe60d9389b7bd98ec360148af781a24b6ebaa213b59ffc36cfcc8421efea14d8ec9f5742a53e019b2221584b5af17e SHA512 a8361ac0e2514626d794e7e4a345b178462409a1f3b53a9318adf171b511c408508acdb07652ad38f34021ac4a614dc5e6d2ea3c6a4ffd261ceef36d3226e573
diff --git a/app-benchmarks/siege/siege-3.1.4.ebuild b/app-benchmarks/siege/siege-3.1.4.ebuild
deleted file mode 100644 (file)
index 46104f6..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-#WANT_AUTOMAKE=1.9
-
-inherit eutils bash-completion-r1 libtool autotools
-
-DESCRIPTION="A HTTP regression testing and benchmarking utility"
-HOMEPAGE="https://www.joedog.org/siege-home/"
-SRC_URI="http://download.joedog.org/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~hppa ~mips ppc x86 ~x64-macos"
-SLOT="0"
-IUSE="libressl ssl"
-
-RDEPEND="ssl? (
-               !libressl? ( dev-libs/openssl:0= )
-               libressl? ( dev-libs/libressl:0= )
-       )"
-DEPEND="${RDEPEND}
-       sys-devel/libtool"
-
-src_prepare() {
-       # bundled macros break recent libtool
-       sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
-       rm *.m4 || die "failed to remove bundled macros"
-       eautoreconf
-}
-
-src_configure() {
-       local myconf
-       use ssl && myconf="--with-ssl=${EPREFIX}/usr" || myconf="--without-ssl"
-       econf ${myconf}
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-
-       dodoc AUTHORS ChangeLog INSTALL README* KNOWNBUGS \
-               doc/siegerc doc/urls.txt
-
-       newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
-}
-
-pkg_postinst() {
-       echo
-       elog "An example ~/.siegerc file has been installed in"
-       elog "${EPREFIX}/usr/share/doc/${PF}/"
-}