games-action/supertuxkart: Drop old 1.0
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 28 Mar 2020 20:33:32 +0000 (20:33 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 28 Mar 2020 20:37:30 +0000 (20:37 +0000)
Package-Manager: Portage-2.3.96, Repoman-2.3.20
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-action/supertuxkart/Manifest
games-action/supertuxkart/files/supertuxkart-0.9.3-irrlicht-arch-support.patch [deleted file]
games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch [deleted file]
games-action/supertuxkart/files/supertuxkart-1.0-system-squish.patch [deleted file]
games-action/supertuxkart/supertuxkart-1.0.ebuild [deleted file]

index fd603cfb6c93364bee04941b1742a5d1efdf0579..4fd966710bca28a087a50d33957461006da9ff33 100644 (file)
@@ -1,3 +1,2 @@
-DIST supertuxkart-1.0-src.tar.xz 597012504 BLAKE2B ed1b851bad8696b4593c54f215b115528afc29bde237f67627e2918c4a9fab09eddc204d0c879fa85c6b10b5544dba5fa5fc1b437cb83e6d884ac717e3369c28 SHA512 182754610abd09545630fa1f7fda858ba1731bbacb078bc71597e143f9cb2a1cfcedd3038720760d0471a89b79cc3bb1eb292d38fcd53be05aad7cb17c474ca9
 DIST supertuxkart-1.1-src.tar.xz 616739152 BLAKE2B a4dd9ec0a8ee158306dc902d3de363b68e7a317800df1b36339843521019df91c0713b74bdef8dc06b40bee57285237408a17b539c7bd7298cd3ef3deaf99fda SHA512 81d5ff59bb33eba8a00547239d54cacfde25eed0c56c857712a00a62032e4cf371cdd367159eaa4bfec6d4dd5781b705e41b58a26b864aa43678cfe9926bb804
 DIST supertuxkart.png 4435 BLAKE2B b48b95e1cdebe930837cc784c4c5e9a089a69077e2fcfed15fe5e8c4d649a0f8024769b2f2102bbaea3a94eb21f4b58b5d291b97493266c3c5c8d7335cf69a80 SHA512 a180332f79220431922fa8b351cb476ebc5d9d1df09f20707eb3bdd7002fd264cb027b8190c73c5221050e6e8601beb6758a5809d05aedfb18f0bdb426f47eda
diff --git a/games-action/supertuxkart/files/supertuxkart-0.9.3-irrlicht-arch-support.patch b/games-action/supertuxkart/files/supertuxkart-0.9.3-irrlicht-arch-support.patch
deleted file mode 100644 (file)
index 6619186..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-From: Christoph Egger <debian@christoph-egger.org>
-Subject: [PATCH] debian/arch-support
-
-Building on non-linux architectures currently fails with unpatched
-irrlicht because irrlicht tries to create Joystick support using
-linux-specific headers. However there's infrastructure to disable
-Joystick support, we just need to activate that on non-linux
-architectures.
-
-Additionally if built on a sparc machine irrlicht assumes wrongly it's
-a solaris system. We fix this wrong assumption as our sparc builds are
-all on linux.
-
-Finally irrlicht exceeds the size constraights for -fpic requiering to
-build with -fPIC. As upstream doesn't do that we need to fix this for
-sparc and s390 builds (powerPC?).
-
-Signed-off-by: Christoph Egger <debian@christoph-egger.org>
-
----
- lib/irrlicht/include/IrrCompileConfig.h |   10 +++++-----
- 1 files changed, 5 insertions(+), 5 deletions(-)
-
---- a/lib/irrlicht/include/IrrCompileConfig.h
-+++ b/lib/irrlicht/include/IrrCompileConfig.h
-@@ -110,4 +110,8 @@
- #ifndef _IRR_SOLARIS_PLATFORM_\r
- #define _IRR_LINUX_PLATFORM_\r
-+#include <endian.h>\r
-+ #if __BYTE_ORDER == __BIG_ENDIAN\r
-+  #define __BIG_ENDIAN__\r
-+ #endif\r
- #endif\r
- #define _IRR_POSIX_API_\r
-@@ -460,11 +464,7 @@
-       #undef _IRR_WCHAR_FILESYSTEM\r
- #endif\r
\r
--#if defined(__sparc__) || defined(__sun__)\r
--#define __BIG_ENDIAN__\r
--#endif\r
--\r
--#if defined(_IRR_SOLARIS_PLATFORM_)\r
-+#if defined(_IRR_SOLARIS_PLATFORM_) || defined(__FreeBSD_kernel__) || defined(__gnu_hurd__)\r
-       #undef _IRR_COMPILE_WITH_JOYSTICK_EVENTS_\r
- #endif\r
\r
diff --git a/games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch b/games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch
deleted file mode 100644 (file)
index 23e8280..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/lib/irrlicht/CMakeLists.txt b/lib/irrlicht/CMakeLists.txt
-index 92a881c81..1371fdf11 100644
---- a/lib/irrlicht/CMakeLists.txt
-+++ b/lib/irrlicht/CMakeLists.txt
-@@ -96,15 +96,6 @@ endif()
- if(WIN32)
-     add_definitions(-D_IRR_STATIC_LIB_)
-     add_definitions(-D_CRT_SECURE_NO_WARNINGS) # Shut up about unsafe stuff
--else()
--    set(CMAKE_C_FLAGS   "${CMAKE_C_FLAGS} -Wall -pipe -O3  -fno-exceptions  -fstrict-aliasing")
--    set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -pipe -O3  -fno-exceptions  -fstrict-aliasing")
--    if(CMAKE_COMPILER_IS_GNUCC)
--        set(CMAKE_C_FLAGS   "${CMAKE_C_FLAGS} -fexpensive-optimizations")
--    endif()
--    if(CMAKE_COMPILER_IS_GNUCXX)
--        set(CMAKE_CXX_FLAGS   "${CMAKE_CXX_FLAGS} -fexpensive-optimizations")
--    endif()
- endif()
- if(USE_GLES2)
diff --git a/games-action/supertuxkart/files/supertuxkart-1.0-system-squish.patch b/games-action/supertuxkart/files/supertuxkart-1.0-system-squish.patch
deleted file mode 100644 (file)
index 8158c4b..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-From e1601b1ae07e3c1ac05cffe05b82e0c60998bc72 Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Mon, 13 May 2019 22:51:21 +0100
-Subject: [PATCH] CMake: Add option to use system Squish library
-
-The system version was preferred before but it wasn't possible to
-explicitly disable it, making its use automagic, which is bad for
-packaging.
-
-Closes: https://github.com/supertuxkart/stk-code/pull/3916
----
- CMakeLists.txt | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 8a7f03264..40e7790fe 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -31,6 +31,8 @@ CMAKE_DEPENDENT_OPTION(BUILD_RECORDER "Build opengl recorder" ON
-     "NOT SERVER_ONLY;NOT APPLE" OFF)
- CMAKE_DEPENDENT_OPTION(USE_FRIBIDI "Support for right-to-left languages" ON
-     "NOT SERVER_ONLY" OFF)
-+CMAKE_DEPENDENT_OPTION(USE_SYSTEM_SQUISH "Use system Squish library instead of the built-in version, when available." ON
-+    "NOT SERVER_ONLY" OFF)
- CMAKE_DEPENDENT_OPTION(USE_WIIUSE "Support for wiimote input devices" ON
-     "NOT SERVER_ONLY;NOT MINGW;NOT CYGWIN" OFF)
-@@ -247,8 +249,10 @@ if(NOT SERVER_ONLY)
- endif()
- if(NOT SERVER_ONLY)
--    find_library(SQUISH_LIBRARY NAMES squish libsquish)
--    find_path(SQUISH_INCLUDEDIR NAMES squish.h PATHS)
-+    if(USE_SYSTEM_SQUISH)
-+        find_library(SQUISH_LIBRARY NAMES squish libsquish)
-+        find_path(SQUISH_INCLUDEDIR NAMES squish.h PATHS)
-+    endif()
-     if (NOT SQUISH_LIBRARY OR NOT SQUISH_INCLUDEDIR)
-         add_subdirectory("${PROJECT_SOURCE_DIR}/lib/libsquish")
-         include_directories("${PROJECT_SOURCE_DIR}/lib/libsquish")
--- 
-2.20.1
-
diff --git a/games-action/supertuxkart/supertuxkart-1.0.ebuild b/games-action/supertuxkart/supertuxkart-1.0.ebuild
deleted file mode 100644 (file)
index 9d7ff7e..0000000
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake desktop xdg-utils
-
-DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
-HOMEPAGE="https://supertuxkart.net/"
-SRC_URI="mirror://sourceforge/${PN}/SuperTuxKart/${PV}/${P}-src.tar.xz
-       mirror://gentoo/${PN}.png"
-
-LICENSE="GPL-2 GPL-3 CC-BY-SA-3.0 CC-BY-SA-4.0 CC0-1.0 public-domain ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug fribidi libressl nettle recorder wiimote"
-
-# don't unbundle irrlicht and bullet
-# both are modified and system versions will break the game
-# https://sourceforge.net/p/irrlicht/feature-requests/138/
-
-RDEPEND="
-       dev-libs/angelscript:=
-       media-libs/freetype:2
-       media-libs/glew:0=
-       media-libs/libpng:0=
-       media-libs/libvorbis
-       media-libs/openal
-       net-libs/enet:1.3=
-       net-misc/curl
-       sys-libs/zlib
-       virtual/glu
-       virtual/jpeg:0
-       virtual/libintl
-       virtual/opengl
-       x11-libs/libX11
-       x11-libs/libXxf86vm
-       fribidi? ( dev-libs/fribidi )
-       nettle? ( dev-libs/nettle:= )
-       !nettle? (
-               libressl? ( dev-libs/libressl:= )
-               !libressl? ( >=dev-libs/openssl-1.0.1d:0= )
-       )
-       recorder? ( media-libs/libopenglrecorder )
-       wiimote? ( net-wireless/bluez )"
-DEPEND="${RDEPEND}"
-BDEPEND="
-       sys-devel/gettext
-       virtual/pkgconfig"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-0.9.3-irrlicht-arch-support.patch
-       "${FILESDIR}"/${PN}-0.9.3-irrlicht-system-libs.patch
-       "${FILESDIR}"/${PN}-1.0-fix-buildsystem.patch
-       "${FILESDIR}"/${PN}-1.0-system-squish.patch
-)
-
-src_prepare() {
-       cmake_src_prepare
-
-       # remove bundled libraries, just to be sure
-       rm -r lib/{angelscript,enet,glew,jpeglib,libpng,zlib} || die
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DUSE_SYSTEM_ANGELSCRIPT=ON
-               -DUSE_SYSTEM_ENET=ON
-               -DUSE_SYSTEM_GLEW=ON
-               -DUSE_SYSTEM_SQUISH=OFF
-               -DUSE_SYSTEM_WIIUSE=OFF
-               -DUSE_CRYPTO_OPENSSL=$(usex nettle no yes)
-               -DENABLE_WAYLAND_DEVICE=OFF
-               -DUSE_FRIBIDI=$(usex fribidi)
-               -DBUILD_RECORDER=$(usex recorder)
-               -DUSE_WIIUSE=$(usex wiimote)
-               -DSTK_INSTALL_BINARY_DIR=bin
-               -DSTK_INSTALL_DATA_DIR=share/${PN}
-               -DBUILD_SHARED_LIBS=OFF # build bundled libsquish as static library
-       )
-       cmake_src_configure
-}
-
-src_install() {
-       cmake_src_install
-       dodoc CHANGELOG.md
-
-       doicon -s 64 "${DISTDIR}"/${PN}.png
-}
-
-pkg_postinst() {
-       xdg_icon_cache_update
-}
-
-pkg_postrm() {
-       xdg_icon_cache_update
-}