dev-python/trollius: Bump to 2.2, remove py3 support
authorMichał Górny <mgorny@gentoo.org>
Mon, 15 Jul 2019 13:14:52 +0000 (15:14 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 15 Jul 2019 13:36:24 +0000 (15:36 +0200)
Bump to the last release which marks the project deprecated.  Remove py3
support since the package has no usefulness for py3, py3.6 fails tests
and py3.7 is entirely broken.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/trollius/Manifest
dev-python/trollius/trollius-2.2.ebuild [new file with mode: 0644]

index 1a2df3a5f4407a96ed0040150bcfbb8baf80cd99..ddaee1f708b2ec925708a6087fd3c0d8ef344ca2 100644 (file)
@@ -1 +1,2 @@
 DIST trollius-2.1.tar.gz 276425 BLAKE2B 3337712e482c19ce06bced64a4169effee74f8e6d33e60f4ab411d636acae586a104766639f63d0075fb12a39f09ed7e54c7396f3295aa99db04e0b60aa433fa SHA512 d800e060e13da22c83fc20f2c0e61d6c50cca309d90e8faecaf24e68240d78ec7fc9cfbb68a968ba7e9d73268e974353d9bd9063eb0ca02a4f0e88610abd6018
+DIST trollius-2.2.tar.gz 276391 BLAKE2B 8debb662498551f2bee85605388813bdcdb720f798b2e2e2cb16a86340fe2759b1a59abcbd6d302e96f6d9860a464c140a521b9a7e731579329351fd11baeebd SHA512 d4a123cc0728eb3548f434ca227a36afce0fca8bfc9fdb0005ff501538c8fad9507608112c4b63c7d273cec2d2310b941068093c9bbdf28d984001753b4956cb
diff --git a/dev-python/trollius/trollius-2.2.ebuild b/dev-python/trollius/trollius-2.2.ebuild
new file mode 100644 (file)
index 0000000..9de2fd0
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Port of the asyncio project to Python 2.7 (deprecated)"
+HOMEPAGE="https://github.com/vstinner/trollius https://pypi.org/project/trollius/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       "${PYTHON}" runtests.py -v 2 || die "Testing failed under ${EPYTHON}"
+}