dev-libs/libassuan: New upstream version 2.5.1
authorKristian Fiskerstrand <k_f@gentoo.org>
Wed, 20 Dec 2017 14:15:52 +0000 (15:15 +0100)
committerKristian Fiskerstrand <k_f@gentoo.org>
Wed, 20 Dec 2017 14:21:53 +0000 (15:21 +0100)
Package-Manager: Portage-2.3.13, Repoman-2.3.3

dev-libs/libassuan/Manifest
dev-libs/libassuan/libassuan-2.5.1.ebuild [new file with mode: 0644]

index ee73e8bea25b652379308182512a280524c21750..84660959bff7ee10b1835565ac4289bf3b3ea331 100644 (file)
@@ -1 +1,2 @@
 DIST libassuan-2.4.3.tar.bz2 559867 BLAKE2B b80f73573449aa1705ac3b4f12f89cac6a19bf4b2ed8f46d5576164196300baeaeb782c997078ac252a564b9f6067df87a340b46c68058d4a28c8291bbecf96b SHA512 2b0f58682b408fc58fa0ec2980b36e54ba66701bf504cf6c98ec652af43501bc7c18573bc78c5b83260f5a3bdb0ec8f4e0662bafd9bba3fe7287e77598e8e4c1
+DIST libassuan-2.5.1.tar.bz2 564857 BLAKE2B dc046b9551183ec543d2a186c3c593471c80445b48aec1366d0b997386c57187f9b7a848973d0930ca8d2be3f138e83c22ef9292e4c8bf5614a99ea3065c7827 SHA512 c8829925221780f175cee8c4084060b0d661229f583a50d400a1903ab7303b2724b99ff9c0fa242881d4c5d779036756e1da54d9143acc0fcd92f302ecb5882d
diff --git a/dev-libs/libassuan/libassuan-2.5.1.ebuild b/dev-libs/libassuan/libassuan-2.5.1.ebuild
new file mode 100644 (file)
index 0000000..603a783
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit libtool ltprune
+
+DESCRIPTION="IPC library used by GnuPG and GPGME"
+HOMEPAGE="http://www.gnupg.org/related_software/libassuan/index.en.html"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/libgpg-error-1.8"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       default
+
+       if [[ ${CHOST} == *-solaris* ]] ; then
+               elibtoolize
+
+               # fix standards conflict
+               sed -i \
+                       -e '/_XOPEN_SOURCE/s/500/600/' \
+                       -e 's/_XOPEN_SOURCE_EXTENDED/_NO&/' \
+                       -e 's/__EXTENSIONS__/_NO&/' \
+                       configure || die
+       fi
+}
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       # ppl need to use libassuan-config for --cflags and --libs
+       prune_libtool_files
+}