dev-python/beautifulsoup: Tweak the chardet blocker
authorMike Gilbert <floppym@gentoo.org>
Sat, 5 Sep 2015 13:16:54 +0000 (09:16 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sat, 5 Sep 2015 13:18:30 +0000 (09:18 -0400)
!dev-python/chardet[${PYTHON_USEDEP}] only blocks chardet if it happens to
have exactly the same python flags enabled.

We also need a hard blocker rather than a soft one.

Package-Manager: portage-2.2.20

dev-python/beautifulsoup/beautifulsoup-4.4.0.ebuild

index a5009b6e05faaa4df125ce60e5c2b42ee5a35880..48f6ba4bab9ed3aae0a6427b5cb5ff20562a826f 100644 (file)
@@ -26,8 +26,9 @@ RDEPEND="$(python_gen_cond_dep 'dev-python/html5lib[${PYTHON_USEDEP}]' python2_7
                $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' python2_7 'python3*')"
 DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? ( dev-python/nose[${PYTHON_USEDEP}]
-               !dev-python/chardet[${PYTHON_USEDEP}] )"
+               !!dev-python/chardet )"
 # See https://bugs.launchpad.net/beautifulsoup/+bug/1471359 to explain need for blocker
+[[ ${PV} == 4.4.0 ]] || die "Don't forget to remove the chardet blocker!"
 
 S=${WORKDIR}/${MY_P}