app-crypt/certbot: 1.3.0 stable amd64 and x86 with cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 4 Apr 2020 20:21:49 +0000 (15:21 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 4 Apr 2020 21:05:42 +0000 (16:05 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-crypt/certbot/Manifest
app-crypt/certbot/certbot-1.2.0-r1.ebuild [deleted file]
app-crypt/certbot/certbot-1.3.0.ebuild

index 3103676a18efb3f69eb97c1eb3ec7a966b66a907..c6644fcb5db8c7ca12540b49f72283f327e4dddd 100644 (file)
@@ -1,2 +1 @@
-DIST certbot-1.2.0.tar.gz 1354262 BLAKE2B 1abdf4cb99ecdac6b9b8d2ebdd6897a3182a147f0175e2db4c6b0feaa3f6c615ee3146dd63627a83266c223456c5aba44b018be4059574d0209aec89065d9925 SHA512 ed52a31a71b3762b8cd217ea2784d9cb01f7c1a50cef3b7e0d99483ca3ab623b90ab7d4896674e0d1c06e2e8370c02162418d934de7d3048b0471416616146fe
 DIST certbot-1.3.0.tar.gz 1362945 BLAKE2B bb36a7737275332f018d7f2283286e07e041892cc366f79e68df9eee7e57ca2186d36895d1923b032068a365878d09e49e17c1399a7418dbd8607c9a7efc1c26 SHA512 4205cdd1f3ddf500b9b952744db234636c086a856df80acd2d776305f4501eed07995e453e5c9b2c711fb0d1f1987d2bb8baaa13fccce8e000a38f486cfdc5d3
diff --git a/app-crypt/certbot/certbot-1.2.0-r1.ebuild b/app-crypt/certbot/certbot-1.2.0-r1.ebuild
deleted file mode 100644 (file)
index cf2fc8b..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=(python{3_6,3_7})
-
-if [[ ${PV} == 9999* ]]; then
-       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
-       inherit git-r3
-else
-       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-fi
-S=${WORKDIR}/${P}/${PN}
-
-inherit distutils-r1
-
-DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="
-       ${CDEPEND}
-       >=app-crypt/acme-0.40.0[${PYTHON_USEDEP}]
-       >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
-       dev-python/configobj[${PYTHON_USEDEP}]
-       >=dev-python/cryptography-2.8[${PYTHON_USEDEP}]
-       >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
-       >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
-       dev-python/mock[${PYTHON_USEDEP}]
-       >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
-       dev-python/pyrfc3339[${PYTHON_USEDEP}]
-       dev-python/pytz[${PYTHON_USEDEP}]
-       dev-python/zope-component[${PYTHON_USEDEP}]
-       dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
-       # required as deps of deps can trigger this too...
-       echo '    ignore:.*collections\.abc:DeprecationWarning' >> ../pytest.ini
-       distutils-r1_python_prepare_all
-}
index c81039179f59f69ed281d6551bd2e0a1cc2e2b01..cf2fc8bb8922271f5ebad17667f039a960727a2d 100644 (file)
@@ -9,7 +9,7 @@ if [[ ${PV} == 9999* ]]; then
        inherit git-r3
 else
        SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+       KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
 fi
 S=${WORKDIR}/${P}/${PN}