dev-ros/rosserial_server: Remove old
authorAlexis Ballier <aballier@gentoo.org>
Wed, 28 Aug 2019 14:58:51 +0000 (16:58 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 28 Aug 2019 17:01:44 +0000 (19:01 +0200)
Package-Manager: Portage-2.3.73, Repoman-2.3.17
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/rosserial_server/Manifest
dev-ros/rosserial_server/files/boost162.patch [deleted file]
dev-ros/rosserial_server/rosserial_server-0.7.4.ebuild [deleted file]
dev-ros/rosserial_server/rosserial_server-0.7.5.ebuild [deleted file]
dev-ros/rosserial_server/rosserial_server-0.7.6.ebuild [deleted file]
dev-ros/rosserial_server/rosserial_server-0.7.7.ebuild [deleted file]

index 10f379fcbe58a6fbd42cf573fafb128538319c1d..7642ef7cb1e147f3989f7d351b13e9d49452d1e9 100644 (file)
@@ -1,5 +1 @@
-DIST rosserial-0.7.4.tar.gz 150244 BLAKE2B 57cc4711f42506587cc6e004f321fe4f4f1ba4e1843a3370ecc50ccb7a26912a4896b31351afaa8e3a02fa07fe7d2b0bb705d248b5a39925873df76c195aaa1f SHA512 a3b9590aeac0a557bee7fa2aa4b561f2dd83dcaff9033425c77cdeca572f4a4ba8fc30b21a3cd035e454e4997d99f9e6541d54739aa9051b9e22d84710e10e00
-DIST rosserial-0.7.5.tar.gz 150687 BLAKE2B 08026b17b08747fd9b1e23a693349f30ff8406cc50f0bd0c949b9367a2b8845b821d69d25e3d35ce9e552e9aa423471e62399ef95c17e35849fcfd858eae6d75 SHA512 3c9ce00b3d95f6d29360aee3b45cb35339ba8646f0f43f64cf1c3f2e77a7c9edbb4f85b761a21a0a3e73cdd064a59c98f997f408a6e8526641499420a94c8a36
-DIST rosserial-0.7.6.tar.gz 151270 BLAKE2B d4082e2eac6c3b2d80bb7c62b6e830a461b7b379c8bad3ea14e44ca8c054e9c78c9605e6a30f6295cbdefc0c7c57133029ebc9042c2d687e3112a703c69400b8 SHA512 adebd29406644c134ab9216f42c1e84dd245b1b1637e055717dea16e82a559c900726c0f6dd9f61e092a3f137805cc96be6f0b100a59574e0818a0bbfb712ea2
-DIST rosserial-0.7.7.tar.gz 155237 BLAKE2B e0e905c9d58face06ceac0e21aa2c72d07961daa5a37f85df6dc39738b27ffa47a9236f2627705c94185891f7d7291dabb80e10fece2eec2c6b76bcbdba7d32a SHA512 fdf880146b7697592288d3f5341f784e2dbadc9639a0b66458709bdee1725e6ca603215296f85e386bc9ad59ca8c3132daf0c33cfb852c10c7c1715c06ff2384
 DIST rosserial-0.8.0.tar.gz 312494 BLAKE2B f65d42ebdc47125a7dfb9b3a999f53640812bc9741f43a5b451fbe449d6d23537face7ca148b2b952c401bb439cee05693f5663e423e70d9df3bbde0d07fbb0a SHA512 ee2f4b3b39fd3be47cbaaed7bfbe08057b1525a12f31dd685d80683ec1ddc89ff43157cc0f09583e68ccc6e35009fda73efa8a74dad6c5bba4b46f4ad6a155d0
diff --git a/dev-ros/rosserial_server/files/boost162.patch b/dev-ros/rosserial_server/files/boost162.patch
deleted file mode 100644 (file)
index d644d40..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-commit f8a46f3142444c854233a85f7a5ec7b91b5378a6
-Author: Malte Splietker <splietker@users.noreply.github.com>
-Date:   Wed Oct 5 04:26:00 2016 +0200
-
-    Fixing build errors for boost >=1.60 (#226) (#250)
-    
-    Signed-off-by: Malte Splietker <maltespl@mail.upb.de>
-
-diff --git a/rosserial_server/include/rosserial_server/session.h b/rosserial_server/include/rosserial_server/session.h
-index 86b9baa..ebd109a 100644
---- a/rosserial_server/include/rosserial_server/session.h
-+++ b/rosserial_server/include/rosserial_server/session.h
-@@ -499,7 +499,7 @@ private:
-   boost::asio::deadline_timer ros_spin_timer_;
-   std::string require_param_name_;
--  std::map<uint16_t, boost::function<void(ros::serialization::IStream)> > callbacks_;
-+  std::map<uint16_t, boost::function<void(ros::serialization::IStream&)> > callbacks_;
-   std::map<uint16_t, PublisherPtr> publishers_;
-   std::map<uint16_t, SubscriberPtr> subscribers_;
-   std::map<std::string, ServiceClientPtr> services_;
-diff --git a/rosserial_server/include/rosserial_server/topic_handlers.h b/rosserial_server/include/rosserial_server/topic_handlers.h
-index 666f3fc..2f367c3 100644
---- a/rosserial_server/include/rosserial_server/topic_handlers.h
-+++ b/rosserial_server/include/rosserial_server/topic_handlers.h
-@@ -93,7 +93,7 @@ typedef boost::shared_ptr<Publisher> PublisherPtr;
- class Subscriber {
- public:
-   Subscriber(ros::NodeHandle& nh, rosserial_msgs::TopicInfo& topic_info,
--      boost::function<void(std::vector<uint8_t> buffer)> write_fn)
-+      boost::function<void(std::vector<uint8_t>& buffer)> write_fn)
-     : write_fn_(write_fn) {
-     ros::SubscribeOptions opts;
-     opts.init<topic_tools::ShapeShifter>(
-@@ -119,7 +119,7 @@ private:
-   }
-   ros::Subscriber subscriber_;
--  boost::function<void(std::vector<uint8_t> buffer)> write_fn_;
-+  boost::function<void(std::vector<uint8_t>& buffer)> write_fn_;
- };
- typedef boost::shared_ptr<Subscriber> SubscriberPtr;
-@@ -127,7 +127,7 @@ typedef boost::shared_ptr<Subscriber> SubscriberPtr;
- class ServiceClient {
- public:
-   ServiceClient(ros::NodeHandle& nh, rosserial_msgs::TopicInfo& topic_info,
--      boost::function<void(std::vector<uint8_t> buffer, const uint16_t topic_id)> write_fn)
-+      boost::function<void(std::vector<uint8_t>& buffer, const uint16_t topic_id)> write_fn)
-     : write_fn_(write_fn) {
-     topic_id_ = -1;
-     if (!service_info_service_.isValid()) {
-@@ -185,7 +185,7 @@ private:
-   topic_tools::ShapeShifter response_message_;
-   ros::ServiceClient service_client_;
-   static ros::ServiceClient service_info_service_;
--  boost::function<void(std::vector<uint8_t> buffer, const uint16_t topic_id)> write_fn_;
-+  boost::function<void(std::vector<uint8_t>& buffer, const uint16_t topic_id)> write_fn_;
-   std::string service_md5_;
-   std::string request_message_md5_;
-   std::string response_message_md5_;
diff --git a/dev-ros/rosserial_server/rosserial_server-0.7.4.ebuild b/dev-ros/rosserial_server/rosserial_server-0.7.4.ebuild
deleted file mode 100644 (file)
index da37baf..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="C++ implementation of the rosserial server side"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       dev-ros/roscpp
-       dev-ros/rosserial_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
-       dev-ros/topic_tools
-       dev-libs/boost:=[threads]
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/boost162.patch" )
diff --git a/dev-ros/rosserial_server/rosserial_server-0.7.5.ebuild b/dev-ros/rosserial_server/rosserial_server-0.7.5.ebuild
deleted file mode 100644 (file)
index 305a25d..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="C++ implementation of the rosserial server side"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       dev-ros/roscpp
-       dev-ros/rosserial_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
-       dev-ros/topic_tools
-       dev-libs/boost:=[threads]
-"
-DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosserial_server/rosserial_server-0.7.6.ebuild b/dev-ros/rosserial_server/rosserial_server-0.7.6.ebuild
deleted file mode 100644 (file)
index 813f62d..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="C++ implementation of the rosserial server side"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       dev-ros/roscpp
-       dev-ros/rosserial_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
-       dev-ros/topic_tools
-       dev-libs/boost:=[threads]
-"
-DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosserial_server/rosserial_server-0.7.7.ebuild b/dev-ros/rosserial_server/rosserial_server-0.7.7.ebuild
deleted file mode 100644 (file)
index 813f62d..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="C++ implementation of the rosserial server side"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       dev-ros/roscpp
-       dev-ros/rosserial_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
-       dev-ros/topic_tools
-       dev-libs/boost:=[threads]
-"
-DEPEND="${RDEPEND}"