dev-vcs/cvsps: update to EAPI=7
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 22 Mar 2020 09:24:44 +0000 (09:24 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 22 Mar 2020 09:24:44 +0000 (09:24 +0000)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-vcs/cvsps/cvsps-2.2_beta1-r1.ebuild [new file with mode: 0644]
dev-vcs/cvsps/files/cvsps-2.1-build.patch
dev-vcs/cvsps/files/cvsps-2.2_beta1-solaris.patch
dev-vcs/cvsps/files/cvsps-3.13-make.patch

diff --git a/dev-vcs/cvsps/cvsps-2.2_beta1-r1.ebuild b/dev-vcs/cvsps/cvsps-2.2_beta1-r1.ebuild
new file mode 100644 (file)
index 0000000..0a94dcb
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils toolchain-funcs
+
+MY_P="${P/_beta/b}"
+DESCRIPTION="Generates patchset information from a CVS repository"
+HOMEPAGE="http://www.catb.org/~esr/cvsps/"
+SRC_URI="http://www.cobite.com/cvsps/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.1-build.patch
+       "${FILESDIR}"/${P}-solaris.patch
+)
+
+src_prepare() {
+       default
+
+       # no configure around
+       if [[ ${CHOST} == *-solaris* ]] ; then
+               sed -i -e '/^LDLIBS+=/s/$/ -lsocket/' Makefile || die
+       fi
+       tc-export CC
+}
+
+src_install() {
+       dobin cvsps
+       doman cvsps.1
+       dodoc README CHANGELOG
+}
index bcb394d5dd0bc6cced7185a10d1d9a3c350f671a..e59f305b99b171ced10f4279bbb1501d8f7026d8 100644 (file)
@@ -1,5 +1,5 @@
---- Makefile.orig      2008-03-24 07:16:47.000000000 -0400
-+++ Makefile   2008-03-24 07:17:18.000000000 -0400
+--- a/Makefile.orig    2008-03-24 07:16:47.000000000 -0400
++++ b/Makefile 2008-03-24 07:17:18.000000000 -0400
 @@ -3,6 +3,7 @@
  CC?=gcc
  CFLAGS?=-g -O2 -Wall 
index 444ac1382a7b4afb2bfde12083f22f3b884fa140..eb8d9e2a94d2685085998602e2cbf65177f41f43 100644 (file)
@@ -1,8 +1,6 @@
 Modified version of.
 http://cvs.openpkg.org/fileview?f=openpkg-src/cvsps/cvsps.patch&v=1.13
 
-diff --git a/cache.c b/cache.c
-index 4c51cf7..2c3918d 100644
 --- a/cache.c
 +++ b/cache.c
 @@ -361,7 +361,7 @@ static void parse_cache_revision(PatchSetMember * psm, const char * p_buff)
@@ -14,8 +12,6 @@ index 4c51cf7..2c3918d 100644
      {
        char * c = strchr(s, ':');
  
-diff --git a/cvs_direct.c b/cvs_direct.c
-index e281848..5aa8f0f 100644
 --- a/cvs_direct.c
 +++ b/cvs_direct.c
 @@ -92,12 +92,12 @@ CvsServerCtx * open_cvs_server(char * p_root, int compress)
@@ -86,8 +82,6 @@ index e281848..5aa8f0f 100644
        if (!tok2)
        {
            debug(DEBUG_APPERROR, "diff_opts parse_error: argument %s requires two arguments", tok);
-diff --git a/util.c b/util.c
-index 7884c84..f3ab3a3 100644
 --- a/util.c
 +++ b/util.c
 @@ -316,3 +316,31 @@ void strcpy_a(char * dst, const char * src, int n)
@@ -122,8 +116,6 @@ index 7884c84..f3ab3a3 100644
 +    return NULL;
 +}
 +
-diff --git a/util.h b/util.h
-index ff2d3a0..336fd63 100644
 --- a/util.h
 +++ b/util.h
 @@ -24,5 +24,6 @@ void timing_stop(const char *);
index 7c96d60300a1e1a6d3ac2702e4cebc11e2a874fe..6263b3b8b749b3b875ed83796a270039e70a7b62 100644 (file)
@@ -1,5 +1,3 @@
-diff --git a/Makefile b/Makefile
-index 6266c9d..4f60d2f 100644
 --- a/Makefile
 +++ b/Makefile
 @@ -8,6 +8,9 @@ INSTALL = install