net-analyzer/arpon: EAPI=7
authorJeroen Roovers <jer@gentoo.org>
Fri, 18 Oct 2019 12:14:41 +0000 (14:14 +0200)
committerJeroen Roovers <jer@gentoo.org>
Fri, 18 Oct 2019 18:11:06 +0000 (20:11 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/arpon/arpon-2.7.2-r1.ebuild [new file with mode: 0644]
net-analyzer/arpon/files/arpon-2.7.2-CFLAGS.patch [new file with mode: 0644]
net-analyzer/arpon/files/arpon-2.7.2-etc.patch [new file with mode: 0644]

diff --git a/net-analyzer/arpon/arpon-2.7.2-r1.ebuild b/net-analyzer/arpon/arpon-2.7.2-r1.ebuild
new file mode 100644 (file)
index 0000000..92f553b
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils
+
+DESCRIPTION="ArpON (Arp handler inspectiON) is a portable Arp handler"
+
+MY_PN="ArpON"
+MY_P="${MY_PN}-${PV}"
+HOMEPAGE="http://arpon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+       dev-libs/libdnet
+       net-libs/libnet:1.1
+       net-libs/libpcap
+"
+RDEPEND="
+       ${DEPEND}
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.7.2-CFLAGS.patch
+       "${FILESDIR}"/${PN}-2.7.2-etc.patch
+)
+DOCS=( AUTHOR CHANGELOG )
+S="${WORKDIR}"/${MY_P}
+
+src_install() {
+       cmake-utils_src_install
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}
+       newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
diff --git a/net-analyzer/arpon/files/arpon-2.7.2-CFLAGS.patch b/net-analyzer/arpon/files/arpon-2.7.2-CFLAGS.patch
new file mode 100644 (file)
index 0000000..525f037
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -51,11 +51,9 @@
+ if(cmake_build_type_tolower STREQUAL "debug")
+   message(STATUS "Build Type: Debug")
+   set(CMAKE_BUILD_TYPE "Debug")
+-  set(CMAKE_C_FLAGS "-Wall -Werror -pedantic -O0 -g")
+ else()
+   message(STATUS "Build Type: Release")
+   set(CMAKE_BUILD_TYPE "Release")
+-  set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Werror")
+ endif()
+ include_directories(
diff --git a/net-analyzer/arpon/files/arpon-2.7.2-etc.patch b/net-analyzer/arpon/files/arpon-2.7.2-etc.patch
new file mode 100644 (file)
index 0000000..03e80f9
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/etc/CMakeLists.txt
++++ b/etc/CMakeLists.txt
+@@ -14,7 +14,7 @@
+     COMPONENT Etcfile)
+ else(${CMAKE_INSTALL_PREFIX} STREQUAL "/")
+   install(FILES ${arpon_etc_src}
+-    DESTINATION ${CMAKE_INSTALL_PREFIX}/etc
++    DESTINATION /etc
+     PERMISSIONS OWNER_READ GROUP_READ WORLD_READ
+     COMPONENT Etcfile)
+ endif(${CMAKE_INSTALL_PREFIX} STREQUAL "/")