dev-python/pycodestyle: version bump
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Thu, 14 May 2020 12:28:11 +0000 (14:28 +0200)
committerMatt Turner <mattst88@gentoo.org>
Tue, 26 May 2020 20:41:47 +0000 (13:41 -0700)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/pycodestyle/Manifest
dev-python/pycodestyle/pycodestyle-2.6.0.ebuild [new file with mode: 0644]

index b0f8d25bc760de7863098df1b650178d483e7ee3..8ed273f0f2d67939f5b9ec60f0d260a94f6594cd 100644 (file)
@@ -1 +1,2 @@
 DIST pycodestyle-2.5.0.tar.gz 98802 BLAKE2B ec86642f0f37abc4da8886df6395694b54cbe4e1d0030615b2136f0bc265825df254f019483e9094feaad685e43008cefdf0e50b533df434a40de0de11aa5fa1 SHA512 84e751a7d00048393b02ca743de5d71d1641e948ee1b4daebbdf2d07e0cd8f087ca4e81f826061114b40ef41920bbcd680c9f479e7cc1a159a70188425717208
+DIST pycodestyle-2.6.0.tar.gz 100213 BLAKE2B 484cad34de86ae50f8efaffe590e79fa52ca7f13a3a9d5c9d52f52aef7a940a9eee8cff74b3bd1f711c3a01155f0ce6794196817d1b0e941b8afc77de4804387 SHA512 3bf9904752170135ca399a1b25470a531adb5b85dfd8df7ffbbc86b5875bc3a507cd8732158bc9cb7fd5b44b48c9a32d63d621856d55a15bc3104a99ca4bd271
diff --git a/dev-python/pycodestyle/pycodestyle-2.6.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.6.0.ebuild
new file mode 100644 (file)
index 0000000..04692ec
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="https://pypi.org/project/pycodestyle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests setup.py
+distutils_enable_sphinx docs
+
+python_test() {
+       PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die
+       PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --max-doc-length=72 --testsuite=testsuite || die
+       PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py --doctest -v || die
+}