Add linguas_de support and font-adobe-utopia-75dpi to RDEPEND
authorTristan Heaven <tristan@gentoo.org>
Fri, 17 Nov 2006 08:45:32 +0000 (08:45 +0000)
committerTristan Heaven <tristan@gentoo.org>
Fri, 17 Nov 2006 08:45:32 +0000 (08:45 +0000)
Package-Manager: portage-2.1.2_rc1-r7

games-strategy/glest/ChangeLog
games-strategy/glest/files/digest-glest-2.0.0-r1
games-strategy/glest/glest-2.0.0-r1.ebuild

index 0abb2c8eb28ce3877b97847ecc31f234bc8eafd8..57780bcb611d472653d9e4e07621f1798acc3d49 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for games-strategy/glest
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.13 2006/08/29 18:04:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.14 2006/11/17 08:45:32 nyhm Exp $
+
+  17 Nov 2006; Tristan Heaven <nyhm@gentoo.org> glest-2.0.0-r1.ebuild:
+  Add linguas_de support and font-adobe-utopia-75dpi to RDEPEND
 
   29 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org>
   glest-2.0.0-r1.ebuild:
index 52eb4eeaeb7f6b52b4e14687478427b1b0a848d9..ee43a79e3625100b2981a89bcee57b6483dc58fc 100644 (file)
@@ -1,3 +1,6 @@
+MD5 266e6aabdaf704e7e409d771d3086eab deutsch_2.0.0.zip 1922
+RMD160 1dbf0dea9cd81cf888533e1b44333159b23dec2d deutsch_2.0.0.zip 1922
+SHA256 5e42bf61a12f4612f4c77e056ea0f6fbdd805343cccd1fa278617a4cb3c7644c deutsch_2.0.0.zip 1922
 MD5 0cc6e7c7029c79f1bf61d3a3bdb441d0 francais_2.0.0.zip 1829
 RMD160 cadacef9e21c8d01435f1d8f28a36e819aaedcc4 francais_2.0.0.zip 1829
 SHA256 812f80b0c322a5387a607d5e73a6cf6942d2918a6308a8900496835d6bb7ec9e francais_2.0.0.zip 1829
index 80af9db73746c9418c0f4f61abfff954d2c39edc..357cecaeecb695307ef4f5c25ff1e7d68bd70ecf 100644 (file)
@@ -1,27 +1,26 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-2.0.0-r1.ebuild,v 1.3 2006/09/19 16:59:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-2.0.0-r1.ebuild,v 1.4 2006/11/17 08:45:32 nyhm Exp $
 
-GAMES_USE_SDL="nojoystick"
-inherit eutils games
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit autotools eutils games
 
-DV="${PV}"
-LV="${PV}"
 L_URI="http://www.glest.org/files/contrib/translations"
-
 DESCRIPTION="Cross-platform 3D realtime strategy game"
 HOMEPAGE="http://www.glest.org/"
 SRC_URI="mirror://sourceforge/${PN}/${PN}_source_${PV}.zip
-       mirror://sourceforge/${PN}/${PN}_data_${DV}.zip
-       linguas_fr? ( ${L_URI}/francais_${LV}.zip )
-       linguas_it? ( ${L_URI}/italiano_${LV}.zip )
-       linguas_pt_BR? ( ${L_URI}/portugues_${LV}.zip )
-       linguas_sk? ( ${L_URI}/slovak_${LV}.zip )"
+       mirror://sourceforge/${PN}/${PN}_data_${PV}.zip
+       linguas_de? ( ${L_URI}/deutsch_${PV}.zip )
+       linguas_fr? ( ${L_URI}/francais_${PV}.zip )
+       linguas_it? ( ${L_URI}/italiano_${PV}.zip )
+       linguas_pt_BR? ( ${L_URI}/portugues_${PV}.zip )
+       linguas_sk? ( ${L_URI}/slovak_${PV}.zip )"
 
 LICENSE="GPL-2 glest-data"
 SLOT="0"
 KEYWORDS="~amd64 -ppc ~x86" # ppc: bug #145478
-IUSE="linguas_fr linguas_it linguas_pt_BR linguas_sk"
+IUSE="linguas_de linguas_fr linguas_it linguas_pt_BR linguas_sk"
 
 RDEPEND=">=media-libs/libsdl-1.2.5
        media-libs/libogg
@@ -30,43 +29,43 @@ RDEPEND=">=media-libs/libsdl-1.2.5
        dev-libs/xerces-c
        virtual/opengl
        virtual/glu
-       || ( x11-libs/libX11 virtual/x11 )"
+       x11-libs/libX11
+       x11-libs/libXt
+       media-fonts/font-adobe-utopia-75dpi"
 DEPEND="${RDEPEND}
        app-arch/unzip
-       || ( x11-libs/libXt virtual/x11 )
-       >=dev-util/jam-2.5"
+       dev-util/jam"
 
 S=${WORKDIR}/${PN}_source_${PV}/mk/linux
 
+GAMES_USE_SDL="nojoystick"
+
 src_unpack() {
        unpack ${A}
+       cd ${PN}_source_${PV}
 
        local file
-       for file in $(find ${PN}_source_${PV} -type f); do
+       for file in $(find . -type f) ; do
                edos2unix "${file}"
        done
 
-       epatch "${FILESDIR}/${P}"-gcc41.patch
-
-       cd ${PN}_source_${PV}
-       epatch "${FILESDIR}/${P}"-home.patch
+       epatch \
+               "${FILESDIR}"/${P}-gcc41.patch \
+               "${FILESDIR}"/${P}-home.patch
 
        sed -i \
                -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
                source/glest_game/main/main.cpp \
-               || die "sed failed"
+               || die "sed main.cpp failed"
 
        cd "${S}"
-       chmod a+x *.sh
-       # sometimes they package configure, sometimes they dont
-       if [[ ! -e configure ]] ; then
+       # sometimes they package configure, sometimes they don't
+       if [[ ! -f configure ]] ; then
+               chmod a+x autogen.sh
                ./autogen.sh || die "autogen failed"
        fi
 
-       sed -i \
-               -e "/COMPILER_CFLAGS_optimize/s:-O3 -g3::" \
-               -e "/COMPILER_C++FLAGS_optimize/s:-O3 -g3::" \
-               Jamrules || die "sed flags failed"
+       sed -i 's:-O3 -g3::' Jamrules || die "sed Jamrules failed"
 }
 
 src_compile() {
@@ -76,36 +75,37 @@ src_compile() {
                --with-ogg=/usr \
                --with-wx-config=disabled_wx \
                || die
-       jam -q ${MAKEOPTS} || die "jam failed"
+       jam -q || die "jam failed"
 }
 
 src_install() {
        dogamesbin glest || die "dogamesbin failed"
 
        insinto "${GAMES_DATADIR}"/${PN}
-       doins glest.ini || die "config copy failed"
+       doins glest.ini || die "doins glest.ini failed"
+       dodoc ../../docs/README.linux
 
        cd "${WORKDIR}"/glest_game
-       insinto "${GAMES_DATADIR}"/${PN}
-       doins -r data maps techs tilesets || die "data copy failed"
+       doins -r data maps techs tilesets || die "doins data failed"
        dodoc docs/readme.txt
 
-       cd ..
-       insinto "${GAMES_DATADIR}"/${PN}/data/lang
-       if use linguas_fr ; then
-               doins francais.lng || die "doins failed"
-       fi
-       if use linguas_it ; then
-               doins italiano2_0_0.lng || die "doins failed"
-       fi
-       if use linguas_pt_BR ; then
-               doins tradu_pt-br.lng || die "doins failed"
-       fi
-       if use linguas_sk ; then
-               doins slovak.lng || die "doins failed"
-       fi
+       make_desktop_entry glest Glest /usr/share/pixmaps/${PN}.bmp
+       newicon techs/magitech/factions/magic/units/archmage/images/archmage.bmp \
+               ${PN}.bmp
 
-       make_desktop_entry glest Glest
+       insinto "${GAMES_DATADIR}"/${PN}/data/lang
+       local lang
+       for lang in ${LINGUAS} ; do
+               case ${lang} in
+                       de) lang=deutsch_2.0.0.lng ;;
+                       fr) lang=francais.lng ;;
+                       it) lang=italiano2_0_0.lng ;;
+                       pt_BR) lang=tradu_pt-br.lng ;;
+                       sk) lang=slovak.lng ;;
+                       *) continue ;;
+               esac
+               doins "${WORKDIR}"/${lang} || die "doins ${lang} failed"
+       done
 
        prepgamesdirs
 }