Upstream developer Niclas Felske <nfelske@gmx.de> has incorporated the buffer overflo...
authorTony Vroon <chainsaw@gentoo.org>
Mon, 4 Dec 2006 13:52:35 +0000 (13:52 +0000)
committerTony Vroon <chainsaw@gentoo.org>
Mon, 4 Dec 2006 13:52:35 +0000 (13:52 +0000)
Package-Manager: portage-2.1.2_rc2-r3

app-mobilephone/smstools/ChangeLog
app-mobilephone/smstools/files/2.2.13-sendsms-chmod.patch [new file with mode: 0644]
app-mobilephone/smstools/files/digest-smstools-2.2.13 [new file with mode: 0644]
app-mobilephone/smstools/smstools-2.2.13.ebuild [new file with mode: 0644]

index 393569bf5ff1db9e397b361143b6c1b735790e24..43a6a4a18b71355d22fcca0461bc91ab5a784d35 100644 (file)
@@ -1,6 +1,16 @@
 # ChangeLog for app-mobilephone/smstools
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/smstools/ChangeLog,v 1.8 2006/12/02 15:29:31 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/smstools/ChangeLog,v 1.9 2006/12/04 13:52:35 chainsaw Exp $
+
+*smstools-2.2.13 (04 Dec 2006)
+
+  04 Dec 2006; Tony Vroon <chainsaw@gentoo.org>
+  -files/2.2.12-buffer-overflow.patch, +files/2.2.13-sendsms-chmod.patch,
+  -files/2.2.12-sendsms-chmod.patch, -smstools-2.2.12-r1.ebuild,
+  +smstools-2.2.13.ebuild:
+  Upstream developer Niclas Felske <nfelske@gmx.de> has incorporated the
+  buffer overflow patch in 2.2.13 and pointed out that the SRC_URI was no
+  longer correct. Closes bug #157077.
 
 *smstools-2.2.12-r1 (02 Dec 2006)
 
diff --git a/app-mobilephone/smstools/files/2.2.13-sendsms-chmod.patch b/app-mobilephone/smstools/files/2.2.13-sendsms-chmod.patch
new file mode 100644 (file)
index 0000000..716e316
--- /dev/null
@@ -0,0 +1,9 @@
+diff -uNr smstools.ORIG/scripts/sendsms smstools/scripts/sendsms
+--- smstools.ORIG/scripts/sendsms      2006-12-02 15:26:09.000000000 +0000
++++ smstools/scripts/sendsms   2006-12-02 15:26:52.000000000 +0000
+@@ -26,3 +26,5 @@
+ echo "" >> $FILE
+ echo -n "$TEXT" >> $FILE
++chmod 660 $FILE
++
diff --git a/app-mobilephone/smstools/files/digest-smstools-2.2.13 b/app-mobilephone/smstools/files/digest-smstools-2.2.13
new file mode 100644 (file)
index 0000000..2daa083
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 eebf0c718a861384ff1b156c45f5d213 smstools-2.2.13.tar.gz 171727
+RMD160 7e2624539334ad38cdd83432cc0623de457a726f smstools-2.2.13.tar.gz 171727
+SHA256 e3d7d31e30830e3f6944ecbda80388a2a1cd3d06d19337ab36c321fb0e71a070 smstools-2.2.13.tar.gz 171727
diff --git a/app-mobilephone/smstools/smstools-2.2.13.ebuild b/app-mobilephone/smstools/smstools-2.2.13.ebuild
new file mode 100644 (file)
index 0000000..fd8e5ca
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/smstools/smstools-2.2.13.ebuild,v 1.1 2006/12/04 13:52:35 chainsaw Exp $
+
+inherit eutils
+
+DESCRIPTION="Send and receive short messages through GSM modems"
+HOMEPAGE="http://smstools.meinemullemaus.de/"
+SRC_URI="http://www.meinemullemaus.de/${PN}/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="stats"
+
+RDEPEND="sys-process/procps
+        stats? ( >=dev-libs/mm-1.4.0 )"
+
+S="${WORKDIR}"/${PN}
+
+pkg_setup() {
+       enewgroup sms
+       enewuser smsd -1 -1 /var/spool/sms sms
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}"/2.2.1-skip-dirlock.patch
+       epatch "${FILESDIR}"/${PV}-sendsms-chmod.patch
+       if use stats; then
+               sed -i -e "s:CFLAGS += -D NOSTATS:#CFLAGS += -D NOSTATS:" src/Makefile
+       fi
+}
+
+src_compile() {
+       cd src
+       emake || die "emake failed"
+}
+
+src_install() {
+       dobin src/smsd
+       cd "${S}"/scripts
+       dobin sendsms sms2html sms2unicode unicode2sms
+       dobin hex2bin hex2dec email2sms
+       dodoc mysmsd smsevent smsresend sms2xml sql_demo
+
+       keepdir /var/spool/sms/incoming
+       keepdir /var/spool/sms/outgoing
+       keepdir /var/spool/sms/checked
+       chown -R smsd:sms "${D}"/var/spool/sms
+
+       newinitd "${FILESDIR}"/smsd.initd smsd
+       insopts -o smsd -g sms -m0644
+       insinto /etc
+       newins "${S}"/examples/smsd.conf.easy smsd.conf
+
+       dohtml "${S}"/doc/*
+}
+
+pkg_preinst() {
+       pkg_setup
+}
+
+pkg_postinst() {
+       chown -f smsd:sms /var/log/smsd.log
+}