x11-libs/librfm: Initial import
authorChristoph Mende <angelos@gentoo.org>
Wed, 7 Oct 2015 16:34:36 +0000 (18:34 +0200)
committerChristoph Mende <angelos@gentoo.org>
Wed, 7 Oct 2015 17:49:58 +0000 (19:49 +0200)
Package-Manager: portage-2.2.22

x11-libs/librfm/Manifest [new file with mode: 0644]
x11-libs/librfm/librfm-5.3.16.3.ebuild [new file with mode: 0644]
x11-libs/librfm/metadata.xml [new file with mode: 0644]

diff --git a/x11-libs/librfm/Manifest b/x11-libs/librfm/Manifest
new file mode 100644 (file)
index 0000000..3f34e25
--- /dev/null
@@ -0,0 +1 @@
+DIST librfm5-5.3.16.3.tar.bz2 3304424 SHA256 326d6be04a39a25246800987299bc224385511c95190490f5bdf813242ec3753 SHA512 e3d00b0337c9368bbe939bcb2d7f6b1c3f3b6b5a810074c5d6bc7afccd938c5284075231a0326b5be2b93436bee346871fb47ee30c130e6ce00756148d214000 WHIRLPOOL 3b24c6d50232f291cb84db379cddbd489a31099a019f4d2c7159e3477ec4459ab0cc7d390b90aebb2a06a7a405d497ce569cdfb02cc43d06b0e210051120ef3d
diff --git a/x11-libs/librfm/librfm-5.3.16.3.ebuild b/x11-libs/librfm/librfm-5.3.16.3.ebuild
new file mode 100644 (file)
index 0000000..ea0262c
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_P=${PN}5-${PV}
+
+DESCRIPTION="the basic library used by some rfm applications, such as Rodent filemanager"
+HOMEPAGE="http://xffm.org/libxffm.html"
+SRC_URI="mirror://sourceforge/xffm/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.22.5:2
+       >=dev-libs/libdbh-5.0.13
+       >=dev-libs/libtubo-5.0.13
+       >=dev-libs/libxml2-2.4.0:2
+       >=dev-libs/libzip-0.9
+       >=gnome-base/librsvg-2.26:2
+       >=x11-libs/cairo-1.12.6
+       >=x11-libs/gtk+-3.12:3
+       >=x11-libs/pango-1.28.0
+       !<x11-misc/rodent-5"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+       DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
+
+src_prepare() {
+       sed -i -e "s:-O2:${CFLAGS}:" m4/rfm-conditionals.m4 || die
+       eautoreconf
+}
+
+src_install() {
+       default
+       prune_libtool_files
+}
diff --git a/x11-libs/librfm/metadata.xml b/x11-libs/librfm/metadata.xml
new file mode 100644 (file)
index 0000000..fcc6fe9
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>angelos@gentoo.org</email>
+               <name>Christoph Mende</name>
+       </maintainer>
+</pkgmetadata>