dev-libs/botan: cleanup old
authorAlon Bar-Lev <alonbl@gentoo.org>
Wed, 8 May 2019 05:51:31 +0000 (08:51 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Wed, 8 May 2019 09:34:53 +0000 (12:34 +0300)
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-libs/botan/Manifest
dev-libs/botan/botan-2.7.0.ebuild [deleted file]
dev-libs/botan/botan-2.8.0.ebuild [deleted file]
dev-libs/botan/files/botan-2.8.0-build.patch [deleted file]

index 77af7e1b3c754684dcb3918d1ff92216f61ab4a9..c2dc54f8d969256c1af0a31c919c9ee45b47bd2b 100644 (file)
@@ -1,4 +1,2 @@
 DIST Botan-1.10.17.tgz 2706678 BLAKE2B bce65493c702381aaa747c2b935c545f85704b93bb6be4bf225048cc14812999291bbbe86786c2b00865489ec47d63128b12ef1020be8651be57fa1c84006a7c SHA512 a47cab3af113652247c8efc8b0f043eb62175eaa8554833d5fc3016ea94dbdd8aa722ab9b5226cc5f133afbcc088d54362111630eaa4594812c39925cc3c8649
-DIST Botan-2.7.0.tgz 7021654 BLAKE2B 3f18b7ba660a72a409beeaba8bd1b1bd021f645c135bed56d75b6ba906b7c28d1e14eac9550862500dda9c4b3ac3135cfc9c340e073c573deb66b236e09f8054 SHA512 992138d83e18aedf80337d825f80c34dd3d2177eb30967573c57cf9fb7e7f9a9965ae3d75f23635f4c93b4efb7bb5adbb3423702663c78a5eb905dd567561858
-DIST Botan-2.8.0.tgz 7152674 BLAKE2B 7838423fc7cc3521b3feb95ab3958f8cd4df86534f1ef30d717b47e54a9a7ae0d2ed6618370b9adfd0a178b509750e5aacda8457caa89f408292837fe3426de0 SHA512 12f734eea3e60a956f75a5b58e9bd83fac7b0dbcd71fb9577b025d171702d87a9a11e2e73162320bdefb2d25f3900757d89dd7fe13089321c88d948efc2ba214
 DIST Botan-2.9.0.tgz 7216373 BLAKE2B 5ad2e15db871ccc3a32b29b7f54a02d69f251f0aca2ce656b557dbbb3814a793053a54905371b3414ad72952a64bece43e2383da91f205f68b0fe31be2f9439c SHA512 b88f3894a4a5b7b2fbff9be6eb0b774bf679a014bd2364811b7e63d4f323e22ca9ef916491afbc2cdf9db68727c1449fbeb6fd417e591560add0955517db3f65
diff --git a/dev-libs/botan/botan-2.7.0.ebuild b/dev-libs/botan/botan-2.7.0.ebuild
deleted file mode 100644 (file)
index dbd4d80..0000000
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit multilib python-r1 toolchain-funcs
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="https://botan.randombit.net/"
-SRC_URI="https://botan.randombit.net/releases/${MY_P}.tgz"
-
-KEYWORDS="amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~ppc-macos"
-SLOT="2/$(ver_cut 1-2)" # soname version
-LICENSE="BSD"
-IUSE="bindist doc boost python bzip2 libressl lzma sqlite ssl static-libs zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="${DEPEND}
-       bzip2? ( >=app-arch/bzip2-1.0.5 )
-       zlib? ( >=sys-libs/zlib-1.2.3 )
-       boost? ( >=dev-libs/boost-1.48 )
-       lzma? ( app-arch/xz-utils )
-       sqlite? ( dev-db/sqlite:3 )
-       ssl? (
-               !libressl? ( dev-libs/openssl:0=[bindist=] )
-               libressl? ( dev-libs/libressl:0= )
-       )"
-BDEPEND="dev-lang/python:*
-       doc? ( dev-python/sphinx )"
-
-src_configure() {
-       local disable_modules=()
-       use boost || disable_modules+=( "boost" )
-       use bindist && disable_modules+=( "ecdsa" )
-       elog "Disabling modules: ${disable_modules[@]}"
-
-       # Enable v9 instructions for sparc64
-       if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
-               CHOSTARCH="sparc32-v9"
-       else
-               CHOSTARCH="${CHOST%%-*}"
-       fi
-
-       local myos=
-       case ${CHOST} in
-               *-darwin*)      myos=darwin ;;
-               *)                      myos=linux  ;;
-       esac
-
-       case ${CHOST} in
-               hppa*)          CHOSTARCH=parisc ;;
-       esac
-
-       local pythonvers=()
-       if use python; then
-               append() {
-                       pythonvers+=( ${EPYTHON/python/} )
-               }
-               python_foreach_impl append
-       fi
-
-       CXX="$(tc-getCXX)" AR="$(tc-getAR)" ./configure.py \
-               $(use_enable static-libs static-library) \
-               $(use_with boost) \
-               $(use_with bzip2) \
-               $(use_with doc documentation) \
-               $(use_with doc sphinx) \
-               $(use_with lzma) \
-               $(use_with sqlite sqlite3) \
-               $(use_with ssl openssl) \
-               $(use_with zlib) \
-               $(usex hppa --without-stack-protector '') \
-               --cc=gcc \
-               --cpu=${CHOSTARCH} \
-               --disable-modules=$(IFS=","; echo "${disable_modules[*]}" ) \
-               --docdir=share/doc \
-               --libdir=$(get_libdir) \
-               --os=${myos} \
-               --prefix="${EPREFIX}/usr" \
-               --with-endian="$(tc-endian)" \
-               --with-python-version=$(IFS=","; echo "${pythonvers[*]}" ) \
-               --without-doxygen \
-               || die "configure.py failed"
-}
-
-src_test() {
-       LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
-}
-
-src_install() {
-       default
-       use python && python_foreach_impl python_optimize
-}
diff --git a/dev-libs/botan/botan-2.8.0.ebuild b/dev-libs/botan/botan-2.8.0.ebuild
deleted file mode 100644 (file)
index e46dbb8..0000000
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit multilib python-r1 toolchain-funcs
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="https://botan.randombit.net/"
-SRC_URI="https://botan.randombit.net/releases/${MY_P}.tgz"
-
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
-SLOT="2/$(ver_cut 1-2)" # soname version
-LICENSE="BSD"
-IUSE="bindist doc boost python bzip2 libressl lzma sqlite ssl static-libs zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="${DEPEND}
-       bzip2? ( >=app-arch/bzip2-1.0.5:= )
-       zlib? ( >=sys-libs/zlib-1.2.3:= )
-       boost? ( >=dev-libs/boost-1.48:= )
-       lzma? ( app-arch/xz-utils:= )
-       sqlite? ( dev-db/sqlite:3= )
-       ssl? (
-               !libressl? ( dev-libs/openssl:0=[bindist=] )
-               libressl? ( dev-libs/libressl:0= )
-       )"
-BDEPEND="dev-lang/python:*
-       doc? ( dev-python/sphinx )"
-
-PATCHES=(
-       "${FILESDIR}/${P}-build.patch"
-)
-
-src_configure() {
-       local disable_modules=()
-       use boost || disable_modules+=( "boost" )
-       use bindist && disable_modules+=( "ecdsa" )
-       elog "Disabling modules: ${disable_modules[@]}"
-
-       # Enable v9 instructions for sparc64
-       if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
-               CHOSTARCH="sparc32-v9"
-       else
-               CHOSTARCH="${CHOST%%-*}"
-       fi
-
-       local myos=
-       case ${CHOST} in
-               *-darwin*)      myos=darwin ;;
-               *)                      myos=linux  ;;
-       esac
-
-       case ${CHOST} in
-               hppa*)          CHOSTARCH=parisc ;;
-       esac
-
-       local pythonvers=()
-       if use python; then
-               append() {
-                       pythonvers+=( ${EPYTHON/python/} )
-               }
-               python_foreach_impl append
-       fi
-
-       CXX="$(tc-getCXX)" AR="$(tc-getAR)" ./configure.py \
-               $(use_enable static-libs static-library) \
-               $(use_with boost) \
-               $(use_with bzip2) \
-               $(use_with doc documentation) \
-               $(use_with doc sphinx) \
-               $(use_with lzma) \
-               $(use_with sqlite sqlite3) \
-               $(use_with ssl openssl) \
-               $(use_with zlib) \
-               $(usex hppa --without-stack-protector '') \
-               --cc=gcc \
-               --cpu=${CHOSTARCH} \
-               --disable-modules=$(IFS=","; echo "${disable_modules[*]}" ) \
-               --docdir=share/doc \
-               --libdir=$(get_libdir) \
-               --os=${myos} \
-               --prefix="${EPREFIX}/usr" \
-               --with-endian="$(tc-endian)" \
-               --with-python-version=$(IFS=","; echo "${pythonvers[*]}" ) \
-               --without-doxygen \
-               || die "configure.py failed"
-}
-
-src_test() {
-       LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
-}
-
-src_install() {
-       default
-       use python && python_foreach_impl python_optimize
-}
diff --git a/dev-libs/botan/files/botan-2.8.0-build.patch b/dev-libs/botan/files/botan-2.8.0-build.patch
deleted file mode 100644 (file)
index 04755a0..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-From 813b7230735960f3e5225f1f74ca680c9ea84101 Mon Sep 17 00:00:00 2001
-From: Shawn Anastasio <shawn@anastas.io>
-Date: Sun, 30 Dec 2018 14:49:43 -0600
-Subject: [PATCH] Add powerpc64le as an alias for ppc64
-
-Add powerpc64le as an alias for the ppc64 build target.
----
- src/build-data/arch/ppc64.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/build-data/arch/ppc64.txt b/src/build-data/arch/ppc64.txt
-index 9ab7cccded..23d3bb2a10 100644
---- a/src/build-data/arch/ppc64.txt
-+++ b/src/build-data/arch/ppc64.txt
-@@ -5,6 +5,7 @@ wordsize 64
- <aliases>
- powerpc64
-+powerpc64le
- ppc64le
- ppc64el
- </aliases>