dev-go/go-tools: fix removal of cover and vet
authorWilliam Hubbs <williamh@gentoo.org>
Thu, 27 Aug 2015 14:53:35 +0000 (09:53 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Thu, 27 Aug 2015 14:56:09 +0000 (09:56 -0500)
Since binaries are being installed in $GOROOT/bin, we need to remove
cover and vet from there for newer versions of go instead of from
removing them from /usr/bin.

This fixes bug #558882.

dev-go/go-tools/go-tools-0_pre20150823-r1.ebuild

index 887effab69f0e3cb62adfa5f7a0f0a5f6a1470eb..030ff9e2a489aa46d59f4a6c45842fee5333d4ee 100644 (file)
@@ -94,7 +94,7 @@ src_install() {
                doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/cover"
                doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/vet"
        else
-               rm "${D}"/usr/bin/{cover,vet} ||
+               rm "${D}"$(go env GOROOT)/bin/{cover,vet} ||
                        die "unable to remove cover and vet"
        fi
 }