sci-astronomy/stellarium: version bump - 0.20.1
authorAlexey Sokolov <sokolov@google.com>
Fri, 10 Apr 2020 01:27:36 +0000 (02:27 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 24 May 2020 21:30:39 +0000 (23:30 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Alexey Sokolov <sokolov@google.com>
Closes: https://bugs.gentoo.org/723078
Closes: https://github.com/gentoo/gentoo/pull/15282
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sci-astronomy/stellarium/Manifest
sci-astronomy/stellarium/stellarium-0.20.1.ebuild [new file with mode: 0644]

index edd57de01192af7ff34389f219a54438853aacfa..156bf5bab2916a7a5b2f551bcccf450244e865c1 100644 (file)
@@ -4,3 +4,4 @@ DIST stars_6_2v0_1.cat 148352404 BLAKE2B c605b284b3d768cb1619ada3f58d406fa7737f0
 DIST stars_7_2v0_1.cat 305710678 BLAKE2B 1cc9b4a6bc35a9339e495f7e0da4f7e90a0e92b05b5de8599be1bbdd2a8053cbcec44b0e58bc9248364666db9cdf23449edf236e3f21fdc0e8f1a4a706afc919 SHA512 43b866eb793e8812c9d5502101a6c985d2055fb88bdbda274726bcd51e1527ecf342b22acd673318c9c8e88cac68eace18de8f27d29ffe64933fd32a5b84c5e3
 DIST stars_8_2v0_1.cat 559068934 BLAKE2B c040a369cdf6885759998e1315b554d21a5e2b9b149a67967a8af45606aebf57bec407fab5ce1904978af0dc529aa6bddd267331ca45f58617bbf56d5ca99dee SHA512 06d4fa298b9dff8452f550377df99fcaa5e7107cfc7b75c9a4769b3cb6d97a822a54213c706102c1d7ef2dabc16df32a85f46b2f6d6c6f76a4e919353b739de4
 DIST stellarium-0.19.3.tar.gz 326218851 BLAKE2B 286d2559a2152f030640ed88778f57f1213d0d8b9e990d0aa1ad5138396fe9641083ec76554e1296dc79d914955e289d23046af42299df6217bbfbaca76b2f18 SHA512 c2948603a3b84fd2b7002cbd9993a2432ca0908d9236aca03c03ff0cf0706728a407218096e94da2b2a623b5434c109906d94ee5069a2d57a8e35af7c8455ff7
+DIST stellarium-0.20.1.tar.gz 343991703 BLAKE2B 59580dd2bca885893bfc68faaf966a727e3d7c0774f59726e23cec132cbfca4ae518983db2e52d4d3d3f1ec96c7ce876168bb23959178ebf212ee6bb357299b3 SHA512 685a306391dc681cc21834a226e35c769e11909f625ff7461d7e896ba412ad595871e93c69981b342099f46829f9f3ef3e276be867dc5ea5523fa60a99cc21d1
diff --git a/sci-astronomy/stellarium/stellarium-0.20.1.ebuild b/sci-astronomy/stellarium/stellarium-0.20.1.ebuild
new file mode 100644 (file)
index 0000000..6be1804
--- /dev/null
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop flag-o-matic xdg virtualx
+
+DESCRIPTION="3D photo-realistic skies in real time"
+HOMEPAGE="https://www.stellarium.org/"
+SRC_URI="
+       https://github.com/Stellarium/stellarium/releases/download/v${PV}/${P}.tar.gz
+       stars? (
+               https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_4_1v0_2.cat
+               https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_5_2v0_1.cat
+               https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_6_2v0_1.cat
+               https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_7_2v0_1.cat
+               https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_8_2v0_1.cat
+       )"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug gps media nls stars test"
+
+BDEPEND="
+       nls? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtopengl:5
+       dev-qt/qtprintsupport:5
+       dev-qt/qtscript:5
+       dev-qt/qtserialport:5
+       dev-qt/qtwidgets:5
+       media-fonts/dejavu
+       sys-libs/zlib
+       virtual/opengl
+       gps? ( dev-qt/qtpositioning:5 )
+       media? ( dev-qt/qtmultimedia:5[widgets] )
+"
+DEPEND="${RDEPEND}
+       dev-qt/qtconcurrent:5
+       test? ( dev-qt/qttest:5 )
+"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+       cmake_src_prepare
+       use debug || append-cppflags -DQT_NO_DEBUG #415769
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DENABLE_GPS="$(usex gps)"
+               -DENABLE_MEDIA="$(usex media)"
+               -DENABLE_NLS="$(usex nls)"
+               -DENABLE_TESTING="$(usex test)"
+       )
+       cmake_src_configure
+}
+
+src_test() {
+       virtx cmake_src_test
+}
+
+src_install() {
+       cmake_src_install
+
+       # use the more up-to-date system fonts
+       rm "${ED}"/usr/share/stellarium/data/DejaVuSans{Mono,}.ttf || die
+       dosym ../../fonts/dejavu/DejaVuSans.ttf /usr/share/stellarium/data/DejaVuSans.ttf
+       dosym ../../fonts/dejavu/DejaVuSansMono.ttf /usr/share/stellarium/data/DejaVuSansMono.ttf
+
+       if use stars ; then
+               insinto /usr/share/${PN}/stars/default
+               doins "${DISTDIR}"/stars_4_1v0_2.cat
+               doins "${DISTDIR}"/stars_{5,6,7,8}_2v0_1.cat
+       fi
+       newicon doc/images/stellarium-logo.png ${PN}.png
+}