Version bump (bug #150385, thanks to Brad Walker), solves bug #148726 . Dropped old...
authorTiziano Müller <dev-zero@gentoo.org>
Fri, 29 Dec 2006 00:57:30 +0000 (00:57 +0000)
committerTiziano Müller <dev-zero@gentoo.org>
Fri, 29 Dec 2006 00:57:30 +0000 (00:57 +0000)
Package-Manager: portage-2.1.2_rc4-r1

dev-python/4suite/4suite-1.0.2.ebuild [new file with mode: 0644]
dev-python/4suite/ChangeLog
dev-python/4suite/files/4suite-1.0.2-amd64_python2.5.patch [new file with mode: 0644]
dev-python/4suite/files/digest-4suite-1.0.2 [new file with mode: 0644]

diff --git a/dev-python/4suite/4suite-1.0.2.ebuild b/dev-python/4suite/4suite-1.0.2.ebuild
new file mode 100644 (file)
index 0000000..429ac7e
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0.2.ebuild,v 1.1 2006/12/29 00:57:30 dev-zero Exp $
+
+inherit distutils eutils multilib
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_P=4Suite-XML-${PV}
+
+DESCRIPTION="Python tools for XML processing and object-databases."
+SRC_URI="mirror://sourceforge/foursuite/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.4suite.org/"
+SLOT="0"
+LICENSE="Apache-1.1"
+IUSE="doc"
+
+DEPEND=">=dev-python/pyxml-0.8.4"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="Ft"
+DOCS="docs/*.txt"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}/${P}-amd64_python2.5.patch"
+}
+
+src_compile() {
+       if ! use doc ; then
+               sed -i -e "/'build_docs'/d" \
+                       Ft/Lib/DistExt/Build.py || die "sed failed"
+       fi
+       distutils_python_version
+       python setup.py config \
+               --prefix=/usr \
+               --docdir=/usr/share/doc/${PF} \
+               --libdir=/usr/$(get_libdir)/4Suite || die "setup.py config failed"
+
+       distutils_src_compile
+}
+
+src_install() {
+       distutils_src_install $(use_with doc docs)
+}
index dbd6a3123c40170afefd855be5c64cb354927fcc..b7d452ddda4343aab2bb82b308bc5499aaaf6973 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for dev-python/4suite
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/ChangeLog,v 1.31 2006/10/20 20:33:40 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/ChangeLog,v 1.32 2006/12/29 00:57:30 dev-zero Exp $
+
+*4suite-1.0.2 (29 Dec 2006)
+
+  29 Dec 2006; Tiziano Müller <dev-zero@gentoo.org>
+  +files/4suite-1.0.2-amd64_python2.5.patch,
+  -files/4S-1.0_a4.addrootopt-gentoo.diff, -4suite-1.0_alpha3.ebuild,
+  -4suite-1.0_beta1.ebuild, +4suite-1.0.2.ebuild:
+  Version bump (bug #150385, thanks to Brad Walker), solves bug #148726 .
+  Dropped old versions.
 
   20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
   4suite-1.0_beta3.ebuild:
diff --git a/dev-python/4suite/files/4suite-1.0.2-amd64_python2.5.patch b/dev-python/4suite/files/4suite-1.0.2-amd64_python2.5.patch
new file mode 100644 (file)
index 0000000..e8c088a
--- /dev/null
@@ -0,0 +1,11 @@
+--- Ft/Lib/DistExt/BuildExt.py.orig    2006-12-29 00:09:54.000000000 +0100
++++ Ft/Lib/DistExt/BuildExt.py 2006-12-29 00:10:37.000000000 +0100
+@@ -61,6 +61,8 @@
+         if (sys.platform.startswith('linux') and
+             sysconfig.get_config_var('Py_ENABLE_SHARED')):
+             libpl, ldlibrary = sysconfig.get_config_vars('LIBPL', 'LDLIBRARY')
++            if libpl not in self.library_dirs:
++                libpl = os.path.join(sys.prefix, 'lib', 'python' + sys.version[:3], 'config')
+             if libpl in self.library_dirs:
+                 if not os.path.exists(os.path.join(libpl, ldlibrary)):
+                     self.library_dirs.remove(libpl)
diff --git a/dev-python/4suite/files/digest-4suite-1.0.2 b/dev-python/4suite/files/digest-4suite-1.0.2
new file mode 100644 (file)
index 0000000..443678d
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b3e976a666899113d58f333518205968 4Suite-XML-1.0.2.tar.bz2 1286713
+RMD160 710de215ac110745a36ab4fec7d718cbcab45bd6 4Suite-XML-1.0.2.tar.bz2 1286713
+SHA256 5a4546dc1fad9b240a46c1b967fae317857cd2d2689e4226de1647083bf6ac3c 4Suite-XML-1.0.2.tar.bz2 1286713