app-backup/borgbackup: allow the use of the msgpack rename w/ fast stable
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 9 Mar 2018 17:25:40 +0000 (11:25 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 9 Mar 2018 17:58:46 +0000 (11:58 -0600)
Package-Manager: Portage-2.3.19, Repoman-2.3.6
RepoMan-Options: --force

app-backup/borgbackup/borgbackup-1.1.3-r1.ebuild [moved from app-backup/borgbackup/borgbackup-1.1.3.ebuild with 83% similarity]
app-backup/borgbackup/borgbackup-1.1.4-r1.ebuild [moved from app-backup/borgbackup/borgbackup-1.1.4.ebuild with 83% similarity]
app-backup/borgbackup/borgbackup-9999.ebuild

similarity index 83%
rename from app-backup/borgbackup/borgbackup-1.1.3.ebuild
rename to app-backup/borgbackup/borgbackup-1.1.3-r1.ebuild
index f0eea83acae88d21a4c5b158890466db425f0ce2..bb6bf0f8a5ee35e8e59ad40400c6eeba6734f322 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -38,3 +38,9 @@ DEPEND="
        dev-python/cython[${PYTHON_USEDEP}]
        ${RDEPEND}
 "
+
+python_prepare_all() {
+       # allow use of new (renamed) msgpack
+       sed -i '/msgpack/d' setup.py || die
+       distutils-r1_python_prepare_all
+}
similarity index 83%
rename from app-backup/borgbackup/borgbackup-1.1.4.ebuild
rename to app-backup/borgbackup/borgbackup-1.1.4-r1.ebuild
index 664c1f81223c3eed523a7855a764a74812f717bd..e04ac14d4248d3214af4e364b1996d572467bd74 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -38,3 +38,9 @@ DEPEND="
        dev-python/cython[${PYTHON_USEDEP}]
        ${RDEPEND}
 "
+
+python_prepare_all() {
+       # allow use of new (renamed) msgpack
+       sed -i '/msgpack/d' setup.py || die
+       distutils-r1_python_prepare_all
+}
index 664c1f81223c3eed523a7855a764a74812f717bd..e04ac14d4248d3214af4e364b1996d572467bd74 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -38,3 +38,9 @@ DEPEND="
        dev-python/cython[${PYTHON_USEDEP}]
        ${RDEPEND}
 "
+
+python_prepare_all() {
+       # allow use of new (renamed) msgpack
+       sed -i '/msgpack/d' setup.py || die
+       distutils-r1_python_prepare_all
+}