sys-devel/heirloom-devtools: Fix gcc6 support, bug #594090 by Peter Levine, also...
authorPacho Ramos <pacho@gentoo.org>
Tue, 4 Apr 2017 11:50:19 +0000 (13:50 +0200)
committerPacho Ramos <pacho@gentoo.org>
Tue, 4 Apr 2017 12:05:07 +0000 (14:05 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

sys-devel/heirloom-devtools/heirloom-devtools-070527-r2.ebuild [moved from sys-devel/heirloom-devtools/heirloom-devtools-070527-r1.ebuild with 65% similarity]
sys-devel/heirloom-devtools/heirloom-devtools-999999.ebuild

similarity index 65%
rename from sys-devel/heirloom-devtools/heirloom-devtools-070527-r1.ebuild
rename to sys-devel/heirloom-devtools/heirloom-devtools-070527-r2.ebuild
index 6b417392c6bea49f0ee00bf095e0d611d4dbf610..53ff1997977975c6db2ac84f32dbffcfd5c54578 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-
-inherit eutils flag-o-matic toolchain-funcs
+EAPI=6
+inherit flag-o-matic readme.gentoo-r1 toolchain-funcs
 
 DESCRIPTION="Original UNIX development tools"
 HOMEPAGE="http://heirloom.sourceforge.net/devtools.html"
@@ -17,8 +16,21 @@ IUSE=""
 DEPEND="app-shells/heirloom-sh"
 RDEPEND="${DEPEND}"
 
-src_prepare() {
+PATCHES=(
+       "${FILESDIR}/${P}-solaris.patch"
+       "${FILESDIR}/${P}-64-bit.patch"
+       "${FILESDIR}/${P}-gcc6.patch"
+)
 
+DOC_CONTENTS="
+       You may want to add /usr/5bin or /usr/ucb to \$PATH
+       to enable using the apps of heirloom toolchest by default.
+       Man pages are installed in /usr/share/man/5man/
+       You may need to set \$MANPATH to access them.
+"
+
+src_prepare() {
+       default
        sed -i \
                -e 's:^\(SHELL =\) \(.*\):\1 /bin/jsh:' \
                -e 's:^\(POSIX_SHELL =\) \(.*\):\1 /bin/sh:' \
@@ -32,12 +44,6 @@ src_prepare() {
                ./mk.config
 
        echo "CC=$(tc-getCC)" >> "./mk.config"
-
-       epatch "${FILESDIR}/${P}-solaris.patch"
-       epatch "${FILESDIR}/${P}-64-bit.patch"
-
-       epatch_user
-
 }
 
 src_compile() {
@@ -46,11 +52,9 @@ src_compile() {
 
 src_install() {
        emake ROOT="${D}" install
+       readme.gentoo_create_doc
 }
 
 pkg_postinst() {
-       elog "You may want to add /usr/5bin or /usr/ucb to \$PATH"
-       elog "to enable using the apps of heirloom toolchest by default."
-       elog "Man pages are installed in /usr/share/man/5man/"
-       elog "You may need to set \$MANPATH to access them."
+       readme.gentoo_print_elog
 }
index 1299aaabeffd93c298bdd2979a8eeb5d4cd221aa..1d97661d245bd30a95cdb1dfbbc95bb956ebe6c7 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-
-inherit cvs flag-o-matic toolchain-funcs
+EAPI=6
+inherit cvs flag-o-matic readme.gentoo-r1 toolchain-funcs
 
 ECVS_AUTH="pserver"
 ECVS_USER="anonymous"
@@ -24,10 +23,17 @@ IUSE=""
 DEPEND="app-shells/heirloom-sh"
 RDEPEND="${DEPEND}"
 
+DOC_CONTENTS="
+       You may want to add /usr/5bin or /usr/ucb to \$PATH
+       to enable using the apps of heirloom toolchest by default.
+       Man pages are installed in /usr/share/man/5man/
+       You may need to set \$MANPATH to access them.
+"
+
 S="${WORKDIR}/${PN}"
 
 src_prepare() {
-
+       default
        sed -i \
                -e 's:^\(SHELL =\) \(.*\):\1 /bin/jsh:' \
                -e 's:^\(POSIX_SHELL =\) \(.*\):\1 /bin/sh:' \
@@ -41,7 +47,6 @@ src_prepare() {
                ./mk.config
 
        echo "CC=$(tc-getCC)" >> "./mk.config"
-
 }
 
 src_compile() {
@@ -50,11 +55,9 @@ src_compile() {
 
 src_install() {
        emake ROOT="${D}" install
+       readme.gentoo_create_doc
 }
 
 pkg_postinst() {
-       elog "You may want to add /usr/5bin or /usr/ucb to \$PATH"
-       elog "to enable using the apps of heirloom toolchest by default."
-       elog "Man pages are installed in /usr/share/man/5man/"
-       elog "You may need to set \$MANPATH to access them."
+       readme.gentoo_print_elog
 }