net-wireless/uhd: fix a ton of QA issues
authorRick Farina <zerochaos@gentoo.org>
Fri, 10 Apr 2020 20:19:40 +0000 (16:19 -0400)
committerRick Farina <zerochaos@gentoo.org>
Fri, 10 Apr 2020 20:19:54 +0000 (16:19 -0400)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
net-wireless/uhd/uhd-3.15.0.0-r1.ebuild [moved from net-wireless/uhd/uhd-3.15.0.0.ebuild with 93% similarity]

similarity index 93%
rename from net-wireless/uhd/uhd-3.15.0.0.ebuild
rename to net-wireless/uhd/uhd-3.15.0.0-r1.ebuild
index aa3efa300c7fbf2fce717cc2abe993ef498c2c96..0bc67971a97cca9047ab8bfe4d69315a4d0c65b5 100644 (file)
@@ -67,6 +67,9 @@ src_prepare() {
 
        #this may not be needed in 3.4.3 and above, please verify
        sed -i 's#SET(PKG_LIB_DIR ${PKG_DATA_DIR})#SET(PKG_LIB_DIR ${LIBRARY_DIR}/uhd)#g' CMakeLists.txt || die
+
+       #rpath is set for apple and no one else, just remove the conditional
+       sed -i -e '/if(APPLE)/d' -e '/endif(APPLE)/d' CMakeLists.txt || die
 }
 
 src_configure() {
@@ -92,11 +95,14 @@ src_configure() {
                -DENABLE_N230="$(usex n230)"
                -DENABLE_MPMD="$(usex mpmd)"
                -DENABLE_OCTOCLOCK="$(usex octoclock)"
+               -DPYTHON_EXECUTABLE="${PYTHON}"
+               -DPKG_DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
        )
        cmake-utils_src_configure
 }
 src_install() {
        cmake-utils_src_install
+       python_optimize
        use utils && python_fix_shebang "${ED}"/usr/$(get_libdir)/${PN}/utils/
        if [ "${PV}" != "9999" ]; then
                rm -rf "${ED}/usr/bin/uhd_images_downloader"