dev-perl/AppConfig: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 12:43:06 +0000 (00:43 +1200)
committerKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 12:45:03 +0000 (00:45 +1200)
- EAPI7
- Parallel Tests

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/AppConfig/AppConfig-1.710.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/AppConfig/AppConfig-1.710.0-r1.ebuild b/dev-perl/AppConfig/AppConfig-1.710.0-r1.ebuild
new file mode 100644 (file)
index 0000000..a18c4e1
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=NEILB
+DIST_VERSION=1.71
+inherit perl-module
+
+DESCRIPTION="Perl5 module for reading configuration files and parsing command line arguments"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-perl/File-HomeDir-0.57
+"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               virtual/perl-Test-Simple
+       )
+"
+src_test() {
+       perl_rm_files t/97-pod.t t/99_author.t
+       perl-module_src_test
+}