dev-libs/jemalloc: bump to v5.2.0
authorThomas Deutschmann <whissi@gentoo.org>
Tue, 11 Jun 2019 23:47:05 +0000 (01:47 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Tue, 11 Jun 2019 23:47:32 +0000 (01:47 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-libs/jemalloc/Manifest
dev-libs/jemalloc/files/jemalloc-5.2.0-fix_html_install.patch [new file with mode: 0644]
dev-libs/jemalloc/jemalloc-5.2.0.ebuild [new file with mode: 0644]

index 53502225ff418840946d766979925bdd288770ff..ff71053391beb14715a2ac07258a6c3136d13cbc 100644 (file)
@@ -3,3 +3,4 @@ DIST jemalloc-4.4.0.tar.bz2 440144 BLAKE2B 6acb91c5be6c5b17c209341dd08e6973e3ad5
 DIST jemalloc-4.5.0.tar.bz2 449992 BLAKE2B 6141c71f7f5f9cee91a59eeed9c69b0a69b3cc39666aa608445073c11ee3ca9b4777a851c5cb5adac80d42bfbf10a6726e5dc1340ffe85ea1ee884d87c7865da SHA512 76953363fe1007952232220afa1a91da4c1c33c02369b5ad239d8dd1d0792141197c15e8489a8f4cd301b08494e65cadd8ecd34d025cb0285700dd78d7248821
 DIST jemalloc-5.0.1.tar.bz2 499300 BLAKE2B 551933fcd93315968cbf89bfadc40313717ff216141af8a131f2333d10090438ddf36fbfdc0ee831cbec6f930ae15aa9cfaafae72ed4f38dd97b00712ca918e8 SHA512 8cb5957a5724eb2bbad120cf0028ea8b2b14b4a416c1751b7c967351a7fd51135058ea0d3c4dc1d127c86f3aa7e9fd5ef101857110aabfdb7789427791c432c3
 DIST jemalloc-5.1.0.tar.bz2 515622 BLAKE2B 3c8b35d30fca0018e3e32452e6fa41c7ac59f9f2f7d4bc243237fde95025ab5a7562fb86b5afe2ca9b7bb072f7baf6ac7589a4862d9ebaafddae187d93e20da0 SHA512 d9abebe54d303ca931b8c31c1033f23ff5fb060f2377ec8386f4d79c352e65c78ed34f680c352dac14f7d7115d10245782d553d988bc13df2eb34a2f0942ef6f
+DIST jemalloc-5.2.0.tar.bz2 543892 BLAKE2B 042dd32452713d0524ae8aedbd3aa96a420037ae3ff0345bbf56a7839ae6ba9e0c700034fab9d5c7b6f4cbb43e2d8199b412901afce16c2785a816d439166e6d SHA512 e3be4d534770126caf10f2684aed9fe4ba1422dd47625fe50343cfb750f26eff869fcc7d1e30a96dd6c73f6614c4bbcd560fd24fc26b55ac731c43e60fd05234
diff --git a/dev-libs/jemalloc/files/jemalloc-5.2.0-fix_html_install.patch b/dev-libs/jemalloc/files/jemalloc-5.2.0-fix_html_install.patch
new file mode 100644 (file)
index 0000000..fe7bcb4
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -511,7 +511,7 @@ install_doc_man:
+       $(INSTALL) -m 644 $$d $(MANDIR)/man3; \
+ done
+-install_doc: build_doc install_doc_html install_doc_man
++install_doc: build_doc install_doc_man
+ install: install_bin install_include install_lib install_doc
diff --git a/dev-libs/jemalloc/jemalloc-5.2.0.ebuild b/dev-libs/jemalloc/jemalloc-5.2.0.ebuild
new file mode 100644 (file)
index 0000000..d2b63f0
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools toolchain-funcs multilib-minimal
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://jemalloc.net/ https://github.com/jemalloc/jemalloc"
+SRC_URI="https://github.com/jemalloc/jemalloc/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE="debug hardened lazy-lock static-libs stats xmalloc"
+HTML_DOCS=( doc/jemalloc.html )
+PATCHES=( "${FILESDIR}/${PN}-5.0.1-strip-optimization.patch"
+       "${FILESDIR}/${PN}-5.2.0-fix_html_install.patch"
+)
+MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
+# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
+# but jemalloc doesn't implement them in its configure; need this here to
+# supress the warnings until automagic is removed from the eclass
+QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+multilib_src_configure() {
+       local myconf=()
+
+       if use hardened ; then
+               myconf+=( --disable-syscall )
+       fi
+
+       ECONF_SOURCE="${S}" \
+       econf  \
+               $(use_enable debug) \
+               $(use_enable lazy-lock) \
+               $(use_enable stats) \
+               $(use_enable xmalloc) \
+               "${myconf[@]}"
+}
+
+multilib_src_install() {
+       # Copy man file which the Makefile looks for
+       cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
+       emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               # fixup install_name, #437362
+               install_name_tool \
+                       -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.2.dylib \
+                       "${ED}"/usr/$(get_libdir)/libjemalloc.2.dylib || die
+       fi
+       use static-libs || find "${ED}" -name '*.a' -delete
+}