net-analyzer/netdata: version bump to 1.5.0
authorCraig Andrews <candrews@integralblue.com>
Mon, 23 Jan 2017 14:52:08 +0000 (09:52 -0500)
committerDavid Seifert <soap@gentoo.org>
Mon, 23 Jan 2017 21:19:28 +0000 (22:19 +0100)
Closes: https://github.com/gentoo/gentoo/pull/3607

net-analyzer/netdata/Manifest
net-analyzer/netdata/netdata-1.5.0.ebuild [new file with mode: 0644]
net-analyzer/netdata/netdata-9999.ebuild

index 80de79611f7ce655924a08108303a9421c774f80..10e5d742a4b46abcdfefba482991a7666ca4e445 100644 (file)
@@ -1,3 +1,4 @@
 DIST netdata-1.2.0.tar.xz 1254000 SHA256 5c1ff3fe0501b654cd92dbba3fe4c0fc125736b58d604340f138df80fb1de1ce SHA512 0c43e89c7cb52a5dde2aec13b06496ffb70fcb1952cf74156bd4400f3520b4136a94b5390077a4e5e3278a8e175dcc14505a456efafec5fdf0759af4846e03f4 WHIRLPOOL 211fabbecfd4b0ffe8f6fb5dbdc28cf08a743c4544e29dd500187547107500c1b42a95677d8de746cce367d4a59c17ff29328c47b0de65208004e6de65d63277
 DIST netdata-1.3.0.tar.xz 1647708 SHA256 bad5d259467ae42ceb0cf5f03fc4b37d094a81f21a772477e6ccc5b8a778bf15 SHA512 0e96f12cbeb7aeecb07b885a0f10940022741633e5cfd76d9f79c9efe3bce2583d96ae18995831fc48d6724f65357929dc5a4220521230ecfb8517f15e779217 WHIRLPOOL 85b87fc6ec76a0255732613606fd4d3000870252c84dbd7be51a2b0132d4d1875d38b61085daeb3ea4e31e522b5e86e05bacf3eb57895ca718cd58501b995955
 DIST netdata-1.4.0.tar.xz 1801440 SHA256 22e293aae156759d220b36ff02fa496548e7386cb4ee53df660fde57418e69ea SHA512 b5f60931372f0c6a437d1340bd9bb07557d8a9ffb478381715495c09c9b9bcf71f287c2e47be40945149a268e0f666289c75cc4eb1d1ab6fc73988f6b71daaf3 WHIRLPOOL ae70a9bca7bf107610e4a81b71f1728a5ffb0721e1c5d53bd2025b8897dbdd6c3569b58bd285e2961243f7d1b501b8ea69c258b5b266ee0bdf04092f62fee249
+DIST netdata-1.5.0.tar.gz 2257299 SHA256 8f66e40ba72ebf5c6e478197eaee3099823fd6380c0870b201f53b5423945338 SHA512 54477c0f9fe2c920580e2e6c3f6c12828f3be2c3dfc1fee47ad98cab51ae3652cb3f223413e9de9399487a35ce844d502ce12fbf615102c0e1962b7dc96a9d95 WHIRLPOOL 2a57636b8ddc6991b6ce18fdb4be73fbd4f658ae0e152eb3c50400c062df87931b3d43b04a31b3857753f7d9ae2ea1a0e62c5235088e20629df1b95abfaf8821
diff --git a/net-analyzer/netdata/netdata-1.5.0.ebuild b/net-analyzer/netdata/netdata-1.5.0.ebuild
new file mode 100644 (file)
index 0000000..ce0d866
--- /dev/null
@@ -0,0 +1,102 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit autotools fcaps linux-info python-r1 systemd user
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="git://github.com/firehol/${PN}.git"
+       inherit git-r3
+       SRC_URI=""
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/firehol/netdata/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Linux real time system monitoring, done right!"
+HOMEPAGE="https://github.com/firehol/netdata https://my-netdata.io/"
+
+LICENSE="GPL-3+ MIT BSD"
+SLOT="0"
+IUSE="+compression cpu_flags_x86_sse2 mysql nfacct nodejs postgres +python"
+REQUIRED_USE="
+       mysql? ( python )
+       python? ( ${PYTHON_REQUIRED_USE} )"
+# most unconditional dependencies are for plugins.d/charts.d.plugin:
+RDEPEND="
+       >=app-shells/bash-4:0
+       net-misc/curl
+       net-misc/wget
+       virtual/awk
+       net-libs/libmnl
+       || ( net-analyzer/netcat6 net-analyzer/netcat )
+       net-analyzer/tcpdump
+       net-analyzer/traceroute
+       compression? ( sys-libs/zlib )
+       python? (
+               ${PYTHON_DEPS}
+               dev-python/pyyaml[${PYTHON_USEDEP}]
+               mysql? (
+                       || ( dev-python/mysqlclient[${PYTHON_USEDEP}] dev-python/mysql-python[${PYTHON_USEDEP}] )
+               )
+               postgres? (
+                       dev-python/psycopg:2[${PYTHON_USEDEP}]
+               )
+       )
+       nfacct? (
+               net-firewall/nfacct
+               net-libs/libmnl
+       )
+       nodejs? (
+               net-libs/nodejs
+       )"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+: ${NETDATA_USER:=netdata}
+: ${NETDATA_GROUP:=netdata}
+
+FILECAPS=(
+       'cap_dac_read_search,cap_sys_ptrace+ep' 'usr/libexec/netdata/plugins.d/apps.plugin'
+)
+
+pkg_setup() {
+       linux-info_pkg_setup
+
+       enewgroup ${PN}
+       enewuser ${PN} -1 -1 / ${PN}
+}
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --localstatedir="${EPREFIX}"/var \
+               --with-user=${NETDATA_USER} \
+               $(use_enable nfacct plugin-nfacct) \
+               $(use_enable cpu_flags_x86_sse2 x86-sse) \
+               $(use_with compression zlib)
+}
+
+src_install() {
+       default
+
+       fowners -Rc ${NETDATA_USER}:${NETDATA_GROUP} /var/log/netdata
+       fowners -Rc ${NETDATA_USER}:${NETDATA_GROUP} /var/cache/netdata
+       fowners -Rc ${NETDATA_USER}:${NETDATA_GROUP} /var/lib/netdata
+
+       fowners -Rc root:${NETDATA_GROUP} /usr/share/${PN}
+
+       newinitd system/netdata-openrc ${PN}
+       systemd_dounit system/netdata.service
+       insinto /etc/netdata
+       doins system/netdata.conf
+}
index e2a78bc9ed58eea612ece16b2293673f838918b2..ce0d866baa5ec4c7203a9dd11b4cda3ac75e6b62 100644 (file)
@@ -1,19 +1,19 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=6
 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
 
-inherit fcaps linux-info python-r1 systemd user
+inherit autotools fcaps linux-info python-r1 systemd user
 
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="git://github.com/firehol/${PN}.git"
-       inherit git-r3 autotools
+       inherit git-r3
        SRC_URI=""
        KEYWORDS=""
 else
-       SRC_URI="https://firehol.org/download/${PN}/releases/v${PV}/${P}.tar.xz"
+       SRC_URI="https://github.com/firehol/netdata/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~x86"
 fi
 
@@ -22,7 +22,7 @@ HOMEPAGE="https://github.com/firehol/netdata https://my-netdata.io/"
 
 LICENSE="GPL-3+ MIT BSD"
 SLOT="0"
-IUSE="+compression cpu_flags_x86_sse2 mysql nfacct nodejs +python"
+IUSE="+compression cpu_flags_x86_sse2 mysql nfacct nodejs postgres +python"
 REQUIRED_USE="
        mysql? ( python )
        python? ( ${PYTHON_REQUIRED_USE} )"
@@ -43,6 +43,9 @@ RDEPEND="
                mysql? (
                        || ( dev-python/mysqlclient[${PYTHON_USEDEP}] dev-python/mysql-python[${PYTHON_USEDEP}] )
                )
+               postgres? (
+                       dev-python/psycopg:2[${PYTHON_USEDEP}]
+               )
        )
        nfacct? (
                net-firewall/nfacct
@@ -71,12 +74,12 @@ pkg_setup() {
 
 src_prepare() {
        default
-       [[ ${PV} == "9999" ]] && eautoreconf
+       eautoreconf
 }
 
 src_configure() {
        econf \
-               --localstatedir=/var \
+               --localstatedir="${EPREFIX}"/var \
                --with-user=${NETDATA_USER} \
                $(use_enable nfacct plugin-nfacct) \
                $(use_enable cpu_flags_x86_sse2 x86-sse) \