app-text/apvlv: Fix gcc6 compilation (#597670)
authorPacho Ramos <pacho@gentoo.org>
Tue, 6 Jun 2017 12:59:07 +0000 (14:59 +0200)
committerPacho Ramos <pacho@gentoo.org>
Tue, 6 Jun 2017 13:02:12 +0000 (15:02 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

app-text/apvlv/apvlv-0.1.5-r1.ebuild
app-text/apvlv/files/apvlv-0.1.5-gcc6.patch [new file with mode: 0644]

index dc6b7a188bc1269db62ef2f817bd8ffbb06319fc..94e7aec162029819a9f10ca6aeef7b18b9754a68 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -26,6 +26,7 @@ DEPEND="${RDEPEND}
 src_prepare() {
        # preserve cflags
        epatch "${FILESDIR}/${PN}-0.1.5-cflags.patch"
+       epatch "${FILESDIR}/${PN}-0.1.5-gcc6.patch"
 }
 
 src_configure() {
diff --git a/app-text/apvlv/files/apvlv-0.1.5-gcc6.patch b/app-text/apvlv/files/apvlv-0.1.5-gcc6.patch
new file mode 100644 (file)
index 0000000..0ffe365
--- /dev/null
@@ -0,0 +1,12 @@
+diff -Naur apvlv-0.1.5.orig/src/ApvlvParams.cc apvlv-0.1.5/src/ApvlvParams.cc
+--- apvlv-0.1.5.orig/src/ApvlvParams.cc        2015-01-10 15:04:24.000000000 +0100
++++ apvlv-0.1.5/src/ApvlvParams.cc     2017-02-09 20:03:08.655402750 +0100
+@@ -90,7 +90,7 @@
+       return false;
+       }
+-    while ((getline (os, str)) != NULL)
++    while (getline (os, str))
+       {
+       string argu, data, crap;
+       stringstream is (str);