net-libs/srt: Version bump
authorLuca Barbato <lu_zero@gentoo.org>
Fri, 22 Nov 2019 09:16:17 +0000 (09:16 +0000)
committerLuca Barbato <lu_zero@gentoo.org>
Fri, 22 Nov 2019 09:18:19 +0000 (09:18 +0000)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
net-libs/srt/Manifest
net-libs/srt/srt-1.4.0.ebuild [new file with mode: 0644]

index 187ef5fee0524eb9b2d067bf8ff771f5c263ab60..a2f532bcdb7ff4b0077890d38458a615fbaba9c1 100644 (file)
@@ -1 +1,2 @@
 DIST srt-1.3.2.tar.gz 812053 BLAKE2B 97e9053fb80da967d0ce90b0276f37d23c93b8c9847910559a12f672c1f224b9069955f57b920417b205374e921f7dbdabf96a66f5cad59e14e85506e5d19d89 SHA512 7cd8b64fafe99c47f82ba3b0c34436353161cd829bbe639038e995a0a39557f9c754a3dcadf4cf7ca587779ce185325ba88e391a058818b84b9ed32212a88817
+DIST srt-1.4.0.tar.gz 1293647 BLAKE2B 93edaa8b1d2b59776bc3efc851a5216e0acef3766b47100646306bb04e3054d4cdf612da07bc5d1124380abe595733393d7e47f1885282a75e24f34b688ddb1e SHA512 b22e7c98b3a5f8ad9647f03bc697254f0f3637716a84b077307f894a193bcf0348c9c10bf09e2ae197f5c721bd6118e2b6134d6770f80eb440783c2d87dd5248
diff --git a/net-libs/srt/srt-1.4.0.ebuild b/net-libs/srt/srt-1.4.0.ebuild
new file mode 100644 (file)
index 0000000..056c2e8
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="Open-source implementation of the Secure Real-time Transport Protocol (SRTP)"
+HOMEPAGE="https://github.com/Haivision/srt"
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/Haivision/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/Haivision/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 -sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="gnutls libressl"
+
+DEPEND="
+       gnutls? (
+               dev-libs/nettle:0=[${MULTILIB_USEDEP}]
+               net-libs/gnutls:0=[${MULTILIB_USEDEP}]
+       )
+       !gnutls? (
+               !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+               libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+       )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md )
+
+PATCHES=(
+       "${FILESDIR}/${PN}-always-GNUInstallDirs.patch"
+)
+
+src_prepare() {
+       cmake-utils_src_prepare
+       sed -i -e "s:hcrypt_ut.c::" "${S}"/haicrypt/*.maf || die
+       sed -i -e 's:DESTINATION lib:DESTINATION lib${LIB_SUFFIX}:' CMakeLists.txt || die
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DUSE_GNUTLS=$(usex gnutls)
+       )
+       cmake-multilib_src_configure
+}