games-engines/frotz: Add missing sound dependencies
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 26 Oct 2019 13:26:28 +0000 (14:26 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 26 Oct 2019 13:26:28 +0000 (14:26 +0100)
libvorbis isn't actually used directly, apart from in the Makefile,
where it's included in the link, presumably for static
linking. Support in libsndfile or libsdl2 is expected to be present
though so I have included it anyway.

I haven't included minimum versions as stated in INSTALL because it
admits that older versions may work and we generally don't bother
unless older versions are still in the tree or were until recently.

Closes: https://bugs.gentoo.org/698434
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-engines/frotz/frotz-2.50_beta2.ebuild

index dda1c12531bd6429c976713c0ec8772d4f9480f7..732495e1c9633134e75d4ca9f0f2cb618c60131b 100644 (file)
@@ -20,13 +20,19 @@ REQUIRED_USE="sound? ( || ( ncurses sdl ) )"
 DEPEND="
        ncurses? (
                sys-libs/ncurses:0=[unicode?]
-               sound? ( media-libs/libao )
+               sound? (
+                       media-libs/libao
+                       media-libs/libmodplug
+                       media-libs/libsamplerate[sndfile]
+                       media-libs/libsndfile[-minimal]
+                       media-libs/libvorbis
+               )
        )
        sdl? (
                media-libs/freetype:2
                media-libs/libpng:0=
                media-libs/libsdl2[sound,threads,video]
-               media-libs/sdl2-mixer
+               media-libs/sdl2-mixer[mod,vorbis,wav]
                sys-libs/zlib
                virtual/jpeg:0=
        )