dev-ruby/rspec-expectations: add ruby27
authorHans de Graaff <graaff@gentoo.org>
Mon, 13 Jan 2020 19:14:12 +0000 (20:14 +0100)
committerHans de Graaff <graaff@gentoo.org>
Mon, 13 Jan 2020 19:24:05 +0000 (20:24 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild

index 1ccac87ba9377b921dd1159dc090856fe53efc64..afe2e00f7f15638069e7760fbcb2466585ac85cb 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
 
 RUBY_FAKEGEM_RECIPE_TEST="rspec"
 
@@ -51,9 +51,5 @@ all_ruby_prepare() {
 }
 
 each_ruby_prepare() {
-       case ${RUBY} in
-               *ruby24|*ruby25|*ruby26)
-                       sed -i -e 's/of Fixnum/of Integer/' spec/rspec/expectations/expectation_target_spec.rb spec/rspec/matchers/be_instance_of_spec.rb || die
-                       ;;
-       esac
+       sed -i -e 's/of Fixnum/of Integer/' spec/rspec/expectations/expectation_target_spec.rb spec/rspec/matchers/be_instance_of_spec.rb || die
 }