app-portage/gverify: Bump to v2
authorMichał Górny <mgorny@gentoo.org>
Wed, 30 Oct 2019 16:32:29 +0000 (17:32 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 30 Oct 2019 16:34:45 +0000 (17:34 +0100)
v2 switches to using Authority Keys and therefore stops failing due
to obsolete gkeys seeds.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/gverify/Manifest
app-portage/gverify/gverify-2.ebuild [new file with mode: 0644]

index 7534034172c90cf9129337880ecd4459aca6a964..c2c1a1925d4b4a8cac9183ce1db0bb86a5ee5a81 100644 (file)
@@ -1 +1,2 @@
 DIST gverify-1.tar.gz 4558 BLAKE2B 193fb63dd3816b4577314199e4f8606a20f60d883f22f36636f1dba4c3fe4a701e89fd352b33ee3ce5bfb10b39e351f971aa55c8cd6eef493fc492e2c4c5d17e SHA512 f666306973bf173683edd845499ea1b244ffc9254ed0d816660022f871e7cec480d452fd962db5417b23d3101496b80a49caece29cbddf3058e2a21ec945a268
+DIST gverify-2.tar.gz 4609 BLAKE2B 73f97ba232fe0269ec56649bc5682650d48c001e432f8076c820a58a94c3d1de079dc89873d589a76b91164153e5c5be78870ef34b3b69f3c39ca0c0e388b114 SHA512 1756671d22047edc6ed1121b65af8c163afba854364a50a9089cef733213ccd6c9dd1276e876b9118741bcfa92ad02cde572fe2b6cebb22339664552c67d2957
diff --git a/app-portage/gverify/gverify-2.ebuild b/app-portage/gverify/gverify-2.ebuild
new file mode 100644 (file)
index 0000000..18068b6
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit python-single-r1
+
+DESCRIPTION="gentoo.git signature verification tool"
+HOMEPAGE="https://github.com/mgorny/gverify"
+SRC_URI="https://github.com/mgorny/gverify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+       app-crypt/gnupg
+       app-crypt/openpgp-keys-gentoo-auth
+       dev-vcs/git"
+DEPEND="${PYTHON_DEPS}"
+
+src_compile() {
+       emake PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+       emake install DESTDIR="${D}" PREFIX=/usr
+       dodoc README
+}