dev-python/libtmux: New package
authorPatrick McLean <patrick.mclean@sony.com>
Fri, 10 May 2019 17:52:28 +0000 (10:52 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Fri, 10 May 2019 17:56:52 +0000 (10:56 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/libtmux/Manifest [new file with mode: 0644]
dev-python/libtmux/libtmux-0.8.1.ebuild [new file with mode: 0644]
dev-python/libtmux/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
new file mode 100644 (file)
index 0000000..f37ff70
--- /dev/null
@@ -0,0 +1 @@
+DIST libtmux-0.8.1.tar.gz 37696 BLAKE2B 48f780ed2c1243c752d35d58f1a7eee4d59297047abcfb0c02c8c9206ad2f8c7df9c2968935e30457dd14be8a9110b9cb1e3b7daf4d5df43e3533e400cd8b21c SHA512 c45e8c761fb9a6b827feff96d4bb263fb0419509a1bd450ac4038d7ad0b96b3047f0d6f3c7bbaa16686918ecfe3c8d189b99982574e4056abf5a491b20e0e7f1
diff --git a/dev-python/libtmux/libtmux-0.8.1.ebuild b/dev-python/libtmux/libtmux-0.8.1.ebuild
new file mode 100644 (file)
index 0000000..517f2c7
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 2019 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="python api for tmux"
+HOMEPAGE="https://libtmux.git-pull.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${BDEPEND}
+       test? (
+               >=dev-python/pytest-4.3.1[${PYTHON_USEDEP}]
+               dev-python/hypothesis[${PYTHON_USEDEP}]
+       )"
+RDEPEND="app-misc/tmux"
+
+# tests aren't included in the dist tarball
+RESTRICT="test"
+
+python_test() {
+       esetup.py test
+}
diff --git a/dev-python/libtmux/metadata.xml b/dev-python/libtmux/metadata.xml
new file mode 100644 (file)
index 0000000..56cae16
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>chutzpah@gentoo.org</email>
+    <name>Patrick McLean</name>
+  </maintainer>
+</pkgmetadata>