gnome-base/librsvg: bump to 2.40.20
authorMart Raudsepp <leio@gentoo.org>
Fri, 14 Dec 2018 22:41:06 +0000 (00:41 +0200)
committerMart Raudsepp <leio@gentoo.org>
Fri, 14 Dec 2018 22:49:19 +0000 (00:49 +0200)
Give up hope of having backported to 2.40.19 test suite machinery
work with its numerous issues (too old freetype generated reference
images, issues for 32-bit, and so on and on), restrict tests and
roll with it. This probably has some security relevant last fixes
for the non-rust version and we should have it, even if tests fail.
Ideally tests will work with the rust requiring versions (on the
architectures that can support, anyways).

Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Package-Manager: Portage-2.3.52, Repoman-2.3.11

gnome-base/librsvg/Manifest
gnome-base/librsvg/librsvg-2.40.20.ebuild [new file with mode: 0644]

index 1381625ce18bb2a9b77d374e2d818dfb3e96a5a4..e0ab80251f6f90c7c0f3404016b47d4f36abc094 100644 (file)
@@ -1 +1,2 @@
 DIST librsvg-2.40.18.tar.xz 574384 BLAKE2B 964997ef3bd5f8bdcab43e67f22d12458683c0eeee2fa81e7a6199f6a31c7ac11c599327a6a66118000f63549ea735a042c71429635f6dc9bf073f12eab067b6 SHA512 faf503d0d881801ce129715e7ae979ee1675bd32beac9170b1889c94aac64caf486968bc86f3480463b84e94f28c1d805551ffdcb7068ecadd0688146e0fb182
+DIST librsvg-2.40.20.tar.xz 1796376 BLAKE2B ec8e7308a0255aa22038262d69019e810bb78b92e3de62662b53ab375110c8186e565e1eb7f5825c61c6d10bed1876ff3f7a06d1073e9676a3d2bb5dfb6b791e SHA512 cdd8224deb4c3786e29f48ed02c32ed9dff5cb15aba574a5ef845801ad3669cfcc3eedb9d359c22213dc7a29de24c363248825adad5877c40abf73b3688ff12f
diff --git a/gnome-base/librsvg/librsvg-2.40.20.ebuild b/gnome-base/librsvg/librsvg-2.40.20.ebuild
new file mode 100644 (file)
index 0000000..e007dc1
--- /dev/null
@@ -0,0 +1,97 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools eutils gnome2 multilib-minimal vala
+
+DESCRIPTION="Scalable Vector Graphics (SVG) rendering library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibRsvg"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="+introspection tools vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+       >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+       >=x11-libs/cairo-1.12.14-r4[${MULTILIB_USEDEP}]
+       >=x11-libs/pango-1.38.0[${MULTILIB_USEDEP}]
+       >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+       >=dev-libs/libcroco-0.6.8-r1[${MULTILIB_USEDEP}]
+       >=x11-libs/gdk-pixbuf-2.30.7:2[introspection?,${MULTILIB_USEDEP}]
+       introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+       tools? ( >=x11-libs/gtk+-3.10.0:3 )
+"
+DEPEND="${RDEPEND}
+       dev-libs/gobject-introspection-common
+       dev-libs/vala-common
+       dev-util/glib-utils
+       >=dev-util/gtk-doc-am-1.13
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+       vala? ( $(vala_depend) )
+"
+# >=gtk-doc-am-1.13, gobject-introspection-common, vala-common needed by eautoreconf
+
+RESTRICT="test" # Lots of issues due to freetype changes and more; ever since newer tests got backported into 2.40.19
+
+src_prepare() {
+       # https://bugzilla.gnome.org/show_bug.cgi?id=653323
+       eapply "${FILESDIR}/${PN}-2.40.12-gtk-optional.patch"
+
+       eautoreconf
+
+       use vala && vala_src_prepare
+       gnome2_src_prepare
+}
+
+multilib_src_configure() {
+       local myconf=()
+
+       # -Bsymbolic is not supported by the Darwin toolchain
+       if [[ ${CHOST} == *-darwin* ]]; then
+               myconf+=( --disable-Bsymbolic )
+       fi
+
+       # --disable-tools even when USE=tools; the tools/ subdirectory is useful
+       # only for librsvg developers
+       ECONF_SOURCE=${S} \
+       gnome2_src_configure \
+               --disable-static \
+               --disable-tools \
+               $(multilib_native_use_enable introspection) \
+               $(multilib_native_use_with tools gtk3) \
+               $(multilib_native_use_enable vala) \
+               --enable-pixbuf-loader \
+               "${myconf[@]}"
+
+       if multilib_is_native_abi; then
+               ln -s "${S}"/doc/html doc/html || die
+       fi
+}
+
+multilib_src_compile() {
+       # causes segfault if set, see bug #411765
+       unset __GL_NO_DSO_FINALIZER
+       gnome2_src_compile
+}
+
+multilib_src_install() {
+       gnome2_src_install
+}
+
+pkg_postinst() {
+       # causes segfault if set, see bug 375615
+       unset __GL_NO_DSO_FINALIZER
+       multilib_foreach_abi gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+       # causes segfault if set, see bug 375615
+       unset __GL_NO_DSO_FINALIZER
+       multilib_foreach_abi gnome2_pkg_postrm
+}