sys-libs/libcxx: Switch live to monorepo
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:34:52 +0000 (09:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 13:15:54 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
sys-libs/libcxx/libcxx-9.0.1.9999.ebuild

index 83d8eeaa8c4002448a814b85e3fd2e53a53bb2aa..9c722cc33620b3994d812cd4e73e4e0f1877284c 100644 (file)
@@ -16,8 +16,8 @@ inherit cmake-multilib git-r3 llvm multiprocessing python-any-r1 \
 DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
 HOMEPAGE="https://libcxx.llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/libcxx.git
-       https://github.com/llvm-mirror/libcxx.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/libcxx
 
 LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
 SLOT="0"
@@ -73,6 +73,11 @@ pkg_setup() {
        fi
 }
 
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' libcxx
+}
+
 test_compiler() {
        $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c++ - \
                <<<'int main() { return 0; }' &>/dev/null
index 5a84e2f5f9982b62a600d58aad3a709b683a8639..f70527cd308e631c2ba82b25ba69cd08248c7f20 100644 (file)
@@ -16,9 +16,9 @@ inherit cmake-multilib git-r3 llvm multiprocessing python-any-r1 \
 DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
 HOMEPAGE="https://libcxx.llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/libcxx.git
-       https://github.com/llvm-mirror/libcxx.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/libcxx
 
 LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
 SLOT="0"
@@ -74,6 +74,11 @@ pkg_setup() {
        fi
 }
 
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' libcxx
+}
+
 test_compiler() {
        $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c++ - \
                <<<'int main() { return 0; }' &>/dev/null