fsharp bump
authorHeather Cynede <cynede@gentoo.org>
Tue, 11 Aug 2015 13:45:44 +0000 (17:45 +0400)
committerHeather Cynede <cynede@gentoo.org>
Tue, 11 Aug 2015 13:47:01 +0000 (17:47 +0400)
Package-Manager: portage-2.2.20

dev-lang/fsharp/Manifest
dev-lang/fsharp/fsharp-3.1.1.31.ebuild
dev-lang/fsharp/fsharp-4.0.0.3.ebuild [new file with mode: 0644]

index c06d43040807edadb7c96be8847b60544c879222..bd53cd440596b07149406c99767fbb81584e8b36 100644 (file)
@@ -1 +1,2 @@
 DIST fsharp-3.1.1.31.tar.gz 31369171 SHA256 9b39c3f4625475c2553668ddbca337ec52fa3a637a05ae14a61a41abe39568b0 SHA512 fcbdad5780a5dd6ab55c380d70b8d0a38f25088e2bb49078468a2cd723b604a14bee6ba2d1005094b1f777a894208654b3f8d3876c5f72126ddc24f96e1eb049 WHIRLPOOL e9060e1e8ccfd3b0efcfeb1148cb5182390e738e8b462746e87d52acaacf5561b53cde50c920a1e4f6929ddf9f3ad0ca6a7d1e9eb8fd3b10af37a375675df019
+DIST fsharp-4.0.0.3.tar.gz 39812344 SHA256 d8a0f2e4504900d973532e1aa28c6758e8f2648898f85ef345437632b5ed1ed2 SHA512 18fae6c20290dec5a0961173875d3b57b9ca6e26d8a4147cf38631752c6feb8202d7726c2f83c30886947388bcc98bae4961f38ae0a169098a004db75e64cd26 WHIRLPOOL e267e156a80edc7d760c3266cb6fe0d5e175e843ebd9cebfa614ecb2fa3bb10f5fe6ee191e3c7bc9e082fb21ac5ce70f8791226b32d2d02313fb8b35009ba5e9
index ef9be8c1c83c1930daa0c102f8fa04497d86dbc9..ef53ae40ae9a754a15cd93a76eb0dc814fd32566 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
+# $Header: $
 
-EAPI="5"
+EAPI=5
 
 AUTOTOOLS_AUTORECONF=1
 
diff --git a/dev-lang/fsharp/fsharp-4.0.0.3.ebuild b/dev-lang/fsharp/fsharp-4.0.0.3.ebuild
new file mode 100644 (file)
index 0000000..ef53ae4
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils mono-env
+
+DESCRIPTION="The F# Compiler"
+HOMEPAGE="https://github.com/fsharp/fsharp"
+SRC_URI="https://github.com/fsharp/fsharp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+MAKEOPTS+=" -j1" #nowarn
+DEPEND="dev-lang/mono"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_install() {
+       autotools-utils_src_install
+}