app-portage/nattka: Bump to 0.0.1
authorMichał Górny <mgorny@gentoo.org>
Thu, 2 Apr 2020 12:19:48 +0000 (14:19 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 2 Apr 2020 14:18:54 +0000 (16:18 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/nattka/Manifest [new file with mode: 0644]
app-portage/nattka/nattka-0.0.1.ebuild [new file with mode: 0644]

diff --git a/app-portage/nattka/Manifest b/app-portage/nattka/Manifest
new file mode 100644 (file)
index 0000000..717e89d
--- /dev/null
@@ -0,0 +1 @@
+DIST nattka-0.0.1.tar.gz 30938 BLAKE2B 1338c5ef1d8cd9c09aaa4502bb94aa2fccabc3b4329ca35005c48f6317e6ae36d5ec9adbbd18a1f86bbe289c8505a0cd5db4159a202514772c3c266b98c60ab7 SHA512 245e6f5e0828c17a98111859a12de0f0401afa33755ed705ff93ecab8e57fa985f6f536b1f4855636a28d74366d924ef6d727e8933e1d01fc17caa8b4b6e5d2b
diff --git a/app-portage/nattka/nattka-0.0.1.ebuild b/app-portage/nattka/nattka-0.0.1.ebuild
new file mode 100644 (file)
index 0000000..93d9d93
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+SRC_URI="https://github.com/mgorny/nattka/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-util/pkgcheck[${PYTHON_USEDEP}]
+       dev-vcs/git
+       sys-apps/pkgcore[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? ( dev-python/vcrpy[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest