www-servers/tornado: bump to 6.0.3; python3_8 added to 5.1-r1
authorAndrey Grozin <grozin@gentoo.org>
Mon, 2 Mar 2020 15:13:02 +0000 (22:13 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Mon, 2 Mar 2020 15:13:02 +0000 (22:13 +0700)
Package-Manager: Portage-2.3.91, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
www-servers/tornado/Manifest
www-servers/tornado/tornado-5.1-r1.ebuild [new file with mode: 0644]
www-servers/tornado/tornado-6.0.3.ebuild [new file with mode: 0644]

index 4d69ed6933eaba4378ec747507fbcabd96d3670c..36be0c9914df3bc659fc4888d158df85e8a5f716 100644 (file)
@@ -3,3 +3,4 @@ DIST tornado-4.5.1.tar.gz 483225 BLAKE2B 261a5da8a7cc43b11b8504162a030fdad9c3c14
 DIST tornado-4.5.3.tar.gz 484221 BLAKE2B 7b3682fa85a7f6ad32351d40993516a3e397b7b0a5de9d807bcd8b2b21325a6170f3670cb13e12aa208b6590313cf165ddf40537dba1fee61fa9d71954265a66 SHA512 c17dd7a3b541c26950d27c8a399ae4fdff1d99d16ff0c5de9871fe2de4c0f797c96712b23b5ed5efdaee06bb251f7def114c83fe6f7f37f344cdac9996d14448
 DIST tornado-5.0.2.tar.gz 506544 BLAKE2B 616298761f5e0cdcacfa96c3a14efaf2cc1d7579d582dc8b2fae2a3a3e45405804aa2a1409665a9af38d2f415908b373c1c34e4ff5868f989bb1bd29fe81a569 SHA512 fbd360df34fe29ed3e5f406992923e2af2815f93446fb9d9810f7575fe06300a2cb15c3f36bd93150284ba297772f94c94a4227acca2dc65c94cf7d100cb5974
 DIST tornado-5.1.tar.gz 516359 BLAKE2B 1ff6e6ced124b7b0df0e476eac555de20e4ac86f01369ee484e33bf5d749c269a81dd11a0b4c8b3169db6fd9f7a1b4e3c3551d46474c53a1fed8e342660c57f9 SHA512 8f45e5bbee5453a4225f05840a9fa80dd574c5a9cac9ec4d787f11c3f86f347c66d39c984a8bbe96dbb41f599e25102f1a3dad1c55b479bebee7d856aaca764a
+DIST tornado-6.0.3.tar.gz 482444 BLAKE2B 1dda4baae52034d779879fef507d5764894f4aa054e60b00a2f8a989df4b31b495cbed6397d602e7c19844ea1538988558d5741da91646b64b6dbb8e78d618ed SHA512 2db182da7327fdd32fe76a50726a1285332139972766368c3b3dac5b4d54b4bd452a76062c09d1d158a97ace78b7915d93a29a7a8138499a2e56aee9df461abc
diff --git a/www-servers/tornado/tornado-5.1-r1.ebuild b/www-servers/tornado/tornado-5.1-r1.ebuild
new file mode 100644 (file)
index 0000000..bc0f928
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="http://www.tornadoweb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+       $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7')
+       >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+       >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+       virtual/python-backports_abc[${PYTHON_USEDEP}]
+       virtual/python-futures[${PYTHON_USEDEP}]
+       virtual/python-singledispatch[${PYTHON_USEDEP}]
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+       )
+       test? (
+               ${CDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="${CDEPEND}"
+
+# doc without intersphinx does not build (asyncio error)
+#PATCHES=(
+#      "${FILESDIR}"/4.5.1-drop-intersphinx.patch
+#)
+
+python_compile_all() {
+       use doc && emake -C docs sphinx
+}
+
+python_test() {
+       "${PYTHON}" -m tornado.test.runtests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/build/html/. )
+       if use examples; then
+               insinto /usr/share/doc/${PF}/examples
+               doins -r demos/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+       distutils-r1_python_install_all
+}
diff --git a/www-servers/tornado/tornado-6.0.3.ebuild b/www-servers/tornado/tornado-6.0.3.ebuild
new file mode 100644 (file)
index 0000000..1350ccb
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="http://www.tornadoweb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+       >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+       >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+       virtual/python-backports_abc[${PYTHON_USEDEP}]
+       virtual/python-futures[${PYTHON_USEDEP}]
+       virtual/python-singledispatch[${PYTHON_USEDEP}]
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+       )
+       test? (
+               ${CDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="${CDEPEND}"
+
+# doc without intersphinx does not build (asyncio error)
+#PATCHES=(
+#      "${FILESDIR}"/4.5.1-drop-intersphinx.patch
+#)
+
+python_compile_all() {
+       use doc && emake -C docs sphinx
+}
+
+python_test() {
+       "${PYTHON}" -m tornado.test.runtests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/build/html/. )
+       if use examples; then
+               insinto /usr/share/doc/${PF}/examples
+               doins -r demos/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+       distutils-r1_python_install_all
+}