Version bump (#49138).
authorDonnie Berkholz <dberkholz@gentoo.org>
Thu, 3 Jun 2004 07:44:06 +0000 (07:44 +0000)
committerDonnie Berkholz <dberkholz@gentoo.org>
Thu, 3 Jun 2004 07:44:06 +0000 (07:44 +0000)
app-sci/gempak/ChangeLog
app-sci/gempak/Manifest
app-sci/gempak/files/digest-gempak-5.7.2_p2 [new file with mode: 0644]
app-sci/gempak/gempak-5.7.2_p2.ebuild [new file with mode: 0644]

index e1493e74265be974407a57e5de01b92f638ccef2..6a6e253abafbc3740d5ed1a96011dc72a243e0bf 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-sci/gempak
 # Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/gempak/ChangeLog,v 1.2 2004/04/19 09:42:48 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gempak/ChangeLog,v 1.3 2004/06/03 07:44:06 spyderous Exp $
+
+*gempak-5.7.2_p2 (03 Jun 2004)
+
+  03 Jun 2004; Donnie Berkholz <spyderous@gentoo.org>;
+  +gempak-5.7.2_p2.ebuild:
+  Version bump (#49138).
 
   19 Apr 2004; Patrick Kursawe <phosphan@gentoo.org> gempak-5.6m.ebuild:
   Adding IUSE
index ae6b71f13d15262f0135f32f4fbeb749a6c3b270..9774212086c8418928b6f8bf24b3ef7266fe8a13 100644 (file)
@@ -1,7 +1,9 @@
 MD5 0a14ddf189b8ffdc4bdc8342de5ca865 gempak-5.6m.ebuild 4986
-MD5 c7f538061f3f3c33b298f84e834e7e67 ChangeLog 592
 MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 39e7076109806924e3a099256cf2f3cb files/digest-gempak-5.6m 72
+MD5 9d99bcdee3b2392c0b8a4435dc33e856 ChangeLog 733
+MD5 c4b653de79cc69af1e5f2be109f31d6c gempak-5.7.2_p2.ebuild 5037
+MD5 97929898710347638aca8dfc11ba2b9f files/Makeinc.common 3395
 MD5 560e697d377c41709d431556bac2944e files/gempak.env.d 1888
+MD5 39e7076109806924e3a099256cf2f3cb files/digest-gempak-5.6m 72
 MD5 1aeb7d2a1b139a694ed2949d4be6c95c files/5.6m-gui.c.patch 11734
-MD5 97929898710347638aca8dfc11ba2b9f files/Makeinc.common 3395
+MD5 760f368f986389c739653dd12ea6dfb8 files/digest-gempak-5.7.2_p2 72
diff --git a/app-sci/gempak/files/digest-gempak-5.7.2_p2 b/app-sci/gempak/files/digest-gempak-5.7.2_p2
new file mode 100644 (file)
index 0000000..d97274e
--- /dev/null
@@ -0,0 +1 @@
+MD5 d8f52abb26f083395a65068d4ecd7725 gempak_upc5.7.2p2.tar.gz 118639087
diff --git a/app-sci/gempak/gempak-5.7.2_p2.ebuild b/app-sci/gempak/gempak-5.7.2_p2.ebuild
new file mode 100644 (file)
index 0000000..fc4759d
--- /dev/null
@@ -0,0 +1,167 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gempak/gempak-5.7.2_p2.ebuild,v 1.1 2004/06/03 07:44:06 spyderous Exp $
+
+inherit gcc eutils
+
+# They can't seem to retain a normal naming scheme, so hacks are required.
+# Often the hacks change on every bump.
+MY_PV="${PV/_}"
+MY_P="${PN}_upc${MY_PV}"
+
+DESCRIPTION="GEMPAK Meteorological Plotting and Analysis Package"
+HOMEPAGE="http://www.unidata.ucar.edu/packages/gempak"
+SRC_URI="${MY_P}.tar.gz"
+LICENSE="as-is"
+DEPEND=""
+RDEPEND="${DEPEND}
+       x11-libs/openmotif
+       !x11-libs/lesstif"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+RESTRICT="fetch"
+# More inconsistencies, this sometimes changes on bumps.
+S="${WORKDIR}/GEMPAK${MY_PV}"
+
+pkg_setup() {
+       # Define this here so we don't have to have it more than once.
+       GENTOO_VARS="NAWIPS GARPHOME GARP_PATH NA_OS GEMPAK GEMPAKHOME GEMLIB GEMEXE
+               GEMPDF GEMTBL GEMERR GEMHLP GEMMAPS GEMNTS GEMPARM GEMPTXT GEMGTXT
+               NAWIPS_EXE NAWIPS_LIB NAWIPS_INC NAWIPS_HELP NAWIPS_TABLES NWX_TABLES
+               NMAP_RESTORE MEL_BUFR MEL_BUFR_TABLES BRDGDIR xresources SCRIPTS_EXE
+               GEMDATA OBS NTRANS_META TEXT_DATA SAT RAD RADDIR LDMDATA GOES8 GOES9 HDS
+               MODEL SAO UPA RAW_SAO RAW_SYN RAW_UPA NLDN TORN_WARN TSTRM_WARN
+               TEXT_WARN RBKGPH LP XUSERFILESEARCHPATH grids"
+}
+
+pkg_nofetch() {
+       einfo "Please visit ${HOMEPAGE}"
+       einfo "and place ${A} in ${DISTDIR}."
+}
+
+src_unpack() {
+       setup_vars
+
+       unpack ${A}
+
+       ebegin "Applying miscellaneous fixes"
+               # Add needed definition
+               sed -e '/^GEMPAKHOME/iNAWIPS           = ${S}' ${FILESDIR}/Makeinc.common >> ${CONFIGDIR}/Makeinc.common
+
+               # One of the GEMPAK cleanup scripts uses '$RM' instead of 'rm'.
+               sed -i -e 's/^\$RM/rm/' ${S}/bin/scripts/cleanvgf
+
+               # Eliminate bad symlink
+               # rm ${S}/unidata/programs/gpnexr2/rsl_colors
+
+               # This is necessary because otherwise it freaks out due to a missing
+               # lib/linux.
+               mkdir -p lib/linux
+       eend 0
+
+       # This is necessary because the paths to some bitmaps are hard-coded.
+       # epatch ${FILESDIR}/${PV}-gui.c.patch
+
+       # Fix changed header
+       header_replace varargs.h stdarg.h
+
+       # Can't install to /usr/local
+       ebegin "Fixing bad install locations"
+               for BADFILE in `grep -lr '/usr/local' ${S}`
+                       do sed -i "s:/usr/local:/usr:g" ${BADFILE} ;
+               done
+       eend 0
+}
+
+src_compile() {
+       setup_vars
+
+       make || die
+}
+
+src_install() {
+       setup_vars
+
+       einfo "Pre-installing GEMPAK..."
+       make install || die
+
+       # This eliminates all the Makefiles, source code, header files, 
+       # and sundry other useless files.
+       ebegin "Removing unnecessary files"
+               rm -rf ${S}/{config,include,ldm,lib,netcdf,nprogs,unidata,gempak/source}
+               rm -rf ${S}/comet/{dcshef,etamap,garp/{gempak,gui,include,init,object,util}}
+               rm ${S}/{,gempak/,comet/{,garp/}}Makefile
+       eend 0
+
+       # Create the directory to install GEMPAK to.
+       dodir usr/gempak
+
+       # Create the skeleton directory hierarchy for GEMPAK data.
+       keepdir usr/gempak/data/images/radar/nids
+       keepdir usr/gempak/data/images/sat/GOES-East
+       keepdir usr/gempak/data/meta
+       keepdir usr/gempak/data/model
+       keepdir usr/gempak/data/nldn
+       keepdir usr/gempak/data/nwx
+       keepdir usr/gempak/data/redbook
+       keepdir usr/gempak/data/surface
+       keepdir usr/gempak/data/upperair
+       dosym usr/gempak/data/model usr/gempak/data/model/hds
+       dosym usr/gempak/data/model usr/gempak/data/model/hrs
+
+       # Put all the necessary files in the correct place.
+       einfo "Installing GEMPAK..."
+       cp -Rfv ${S}/* ${D}/usr/gempak
+
+       # This is necessary, because otherwise some of the files will not be
+       # world-readable
+       ebegin "Fixing permissions to ensure world-readability"
+               chmod +r -Rf ${D}
+       eend 0
+
+       # Install env.d file
+       insinto /etc/env.d
+       newins ${FILESDIR}/gempak.env.d 10gempak
+}
+
+pkg_postinst() {
+       einfo ""
+       einfo "A skeleton directory hierarchy has been automatically"
+       einfo "created in /usr/gempak/data.  If you wish to use a"
+       einfo "different path you will need to edit /etc/env.d/10gempak"
+       einfo "to reflect the change.  If you already have a directory"
+       einfo "hierarchy of your own, then simply remove /usr/gempak/data"
+       einfo "and create a symbolic link from your data path to"
+       einfo "/usr/gempak/data.  Updates/uninstalls of GEMPAK will not"
+       einfo "affect the symlinked directories, so long as they have data"
+       einfo "inside them."
+       einfo ""
+       einfo "NOTE:  Some of the programs in the GEMPAK suite have paths"
+       einfo "hardcoded into the executables. It is ill-advised"
+       einfo "to start playing around with paths unless you know"
+       einfo "what you are doing."
+       einfo ""
+}
+
+header_replace() {
+       # Replace obsoleted header
+       # Usage: header_fix oldheader newheader
+       ebegin "Replacing obsolete header references"
+               for OLDFILE in `grep -lr "${1}" ${S}`
+                       do sed -i "s:${1}:${2}:g" ${OLDFILE} ;
+               done
+       eend 0
+}
+
+setup_vars() {
+       # All GEMPAK paths need to be unset before attempting to compile.
+       unset ${GENTOO_VARS}
+
+       # These GEMPAK paths must be set to their new values before
+       # compiling.
+       export CONFIGDIR="${S}/config"
+       export GARPHOME="${S}/comet/garp"
+       export NA_OS="linux"
+       export NAWIPS="${S}"
+}