net-analyzer/nfdump: Version 1.6.20
authorJeroen Roovers <jer@gentoo.org>
Sun, 29 Mar 2020 12:35:09 +0000 (14:35 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sun, 29 Mar 2020 12:38:07 +0000 (14:38 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/nfdump/Manifest
net-analyzer/nfdump/nfdump-1.6.20.ebuild [new file with mode: 0644]

index fb7111a4d53d39b42c0c94984aeaad285a8622f7..a576e2cdefd2a0e22ce5ea659bfd8077b89d1a52 100644 (file)
@@ -1 +1,2 @@
 DIST nfdump-1.6.19.tar.gz 561923 BLAKE2B 458cf0e23f433c7c1c27450712a2f9f8f75a990eeaf079bac9a74bf5abf4bc22c930294494424fd8e7f7d03ffc1e5f1e35ba50e29ba4f3528f63e1739524c9ed SHA512 577c23ca3aae8ab035c734c137d3a338e09f46b5f8551946fd84b9a03fae1ef2aa80e2ab9657eb226defcd753bb63503eeb85316ca1df18d95b85270df8f379e
+DIST nfdump-1.6.20.tar.gz 561053 BLAKE2B 20c8db09386a4aa6174d3c2919c33409a4b2d9b295908ae61e8ce12107c08ba7742fb7ec80bcb7bcdb15e036e6d2320c83f0446a479185cb18717720eca87c88 SHA512 8396241fa24d532540135762a81ce035586c405d4ab1e01d6e2b8226b7cc9b6784170ca1fa4c1581fb60f324473cca5ce2d3de82282313d3877f9584e449d137
diff --git a/net-analyzer/nfdump/nfdump-1.6.20.ebuild b/net-analyzer/nfdump/nfdump-1.6.20.ebuild
new file mode 100644 (file)
index 0000000..d866f89
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A set of tools to collect and process netflow data"
+HOMEPAGE="https://github.com/phaag/nfdump"
+SRC_URI="https://github.com/phaag/nfdump/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/1.6.15"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ftconv nfprofile nftrack readpcap sflow static-libs"
+
+COMMON_DEPEND="
+       app-arch/bzip2
+       sys-libs/zlib
+       ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
+       nfprofile? ( net-analyzer/rrdtool )
+       nftrack? ( net-analyzer/rrdtool )
+       readpcap? ( net-libs/libpcap )
+"
+DEPEND="
+       ${COMMON_DEPEND}
+       app-doc/doxygen
+       sys-devel/flex
+       virtual/yacc
+"
+RDEPEND="
+       ${COMMON_DEPEND}
+       dev-lang/perl
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.6.19-compiler.patch
+       "${FILESDIR}"/${PN}-1.6.19-libft.patch
+)
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_prepare() {
+       default
+
+       eautoreconf
+
+       doxygen -u doc/Doxyfile.in || die
+}
+
+src_configure() {
+       # --without-ftconf is not handled well #322201
+       econf \
+               $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
+               $(use nfprofile && echo --enable-nfprofile) \
+               $(use nftrack && echo --enable-nftrack) \
+               $(use_enable debug devel) \
+               $(use_enable readpcap) \
+               $(use_enable sflow) \
+               $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       find "${ED}" -name '*.la' -delete || die
+}