dev-python/loguru: drop 0.3.1
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 22 Aug 2019 01:06:04 +0000 (18:06 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 22 Aug 2019 01:06:04 +0000 (18:06 -0700)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-python/loguru/Manifest
dev-python/loguru/loguru-0.3.1.ebuild [deleted file]

index 96970fa64972061eb64592fa82470459cc6620e7..1ff209a5d790da937679f4007c8e46697e05f871 100644 (file)
@@ -1,2 +1 @@
-DIST loguru-0.3.1.tar.gz 377834 BLAKE2B 4402a6dfd8e36efb966eb0f31ba2161183c03a7072f45ef86110587b1f3653e4711c0461d39d5e0047fb7b84c7da417c011644ffee815f82bf1f4847588b17b8 SHA512 b0b75aa265839be0a522101671bf9992c1fe548439988a5c2feb58702be77944137e4f78920ec5dd4fe5953daf7160714a4de940527d0987dba4907ac27a0e15
 DIST loguru-0.3.2.tar.gz 378160 BLAKE2B 83301f5bb79d0edb20d211e8ee4d05b3b93a0a9f13f13b2ff103f1e9759f227b80e5571ccda48098a1e45658d99a54768fdf456ffef7a13d08375ce62ad876e1 SHA512 e78f5f43fbf4891ff9b9a21c1a29e4f02877f73a09b7b7df25076bffb25a094eef561c469b22cbb999979de4dbf81df2298681fa219dc684f15fe7c52ecb5359
diff --git a/dev-python/loguru/loguru-0.3.1.ebuild b/dev-python/loguru/loguru-0.3.1.ebuild
deleted file mode 100644 (file)
index f3f3408..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{5,6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python logging made (stupidly) simple"
-HOMEPAGE="https://github.com/Delgan/loguru"
-SRC_URI="https://github.com/Delgan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/colorama-0.3.4[${PYTHON_USEDEP}]"
-
-DEPEND="
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-       )
-       test? (
-               ${RDEPEND}
-               >=dev-python/colorama-0.3.4[${PYTHON_USEDEP}]
-               >=dev-python/pytest-4.5.0[${PYTHON_USEDEP}]
-       )
-"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx
-}
-
-python_install_all() {
-       use doc && HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
-       distutils-r1_python_install_all
-}
-
-python_test() {
-       distutils_install_for_testing
-       pytest -vv || die "Tests failed with ${EPYTHON}"
-}