net-print/cups-filters: Bump to version 1.25.0
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Jun 2019 08:37:53 +0000 (10:37 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Jun 2019 08:47:42 +0000 (10:47 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-print/cups-filters/Manifest
net-print/cups-filters/cups-filters-1.25.0.ebuild [new file with mode: 0644]

index 22c48834484afeb672141b58c5ccfa92a2f3afcf..f348248fb53f0dbc5b4a593474d8be56cacddf30 100644 (file)
@@ -2,3 +2,4 @@ DIST cups-filters-1.21.6.tar.xz 1474944 BLAKE2B a4c3418accb9d2bf46a366ec6004919d
 DIST cups-filters-1.22.5.tar.xz 1476792 BLAKE2B 77efec3c6c8287b22ab96185e609e8da30ebd20d9c944ba0a3057bd1469e12d30cf6775988500e4f410410160d8766df1d6432e81116cbf926e7c75f49cddb5d SHA512 ed33e6d6f090c00f0f0d1d012d3b394bfaa1f81feeb5b0b7ead1dffa2399f0165ce916a99c3bf28aca7f279bffba5b6575feff700130cabfcd46eb4c904d5c59
 DIST cups-filters-1.22.6.tar.xz 1477584 BLAKE2B 7d833c3e97c510eabcc906bbd01d4d1ef2bf3106d963bdec7f735942e96a830c53ec2c03a4ef580d9fc01f19bae3962c1bd2a98d2af7f03f71988ae374366fee SHA512 6c1c46bd74f700b3ab0a46cb4b5b7ecc93000122e9deb20b43878d876cbe2ceeeb4a3c16ef6de00497b10447d04f2689a5d939d0d49212e7274cc51b4617c296
 DIST cups-filters-1.23.0.tar.xz 1477900 BLAKE2B 00a67ace059c9c280dbd4019fbfec61ef1e46bc2b5c9e36019e860c32a8b4277abefb9cf290e7d8629450c7022099157910703bda2366a0700e3e973fd44a110 SHA512 466dc14155750f8868f29fe416c061813b661892aba7bf91446e1145da5c7eb23abf9935a19d2309bfcb521c44eab9d4404db7965c95b9578e10cccd26bbba8f
+DIST cups-filters-1.25.0.tar.xz 1447496 BLAKE2B 297f16a5580787ccf1494ae99a90ed5912156e255394e3d3e921d8e29db9f94b0ed8409b641bec5231dfc0c802b773415beaf4103424cc2cb46d25d9f3804d8e SHA512 f1be31721fd8f6192868e7954d94038ff1382bb0194bb64014da3dd695cbbd2cd5d65373d809e1b541071374b7eabb44c68c6be29575251490d76a0a5336a5c5
diff --git a/net-print/cups-filters/cups-filters-1.25.0.ebuild b/net-print/cups-filters/cups-filters-1.25.0.ebuild
new file mode 100644 (file)
index 0000000..9549f96
--- /dev/null
@@ -0,0 +1,135 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+       inherit autotools git-r3
+       EGIT_REPO_URI="https://github.com/OpenPrinting/cups-filters.git"
+else
+       SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic ipp_autosetup jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+
+RDEPEND="
+       >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+       >=app-text/qpdf-8.3.0:=
+       dev-libs/glib:2
+       media-libs/fontconfig
+       media-libs/freetype:2
+       media-libs/lcms:2
+       >=net-print/cups-1.7.3
+       !<=net-print/cups-1.5.9999
+       sys-devel/bc
+       sys-libs/zlib
+       dbus? ( sys-apps/dbus )
+       foomatic? ( !net-print/foomatic-filters )
+       jpeg? ( virtual/jpeg:0 )
+       ldap? ( net-nds/openldap )
+       pdf? ( app-text/mupdf )
+       perl? ( dev-lang/perl:= )
+       png? ( media-libs/libpng:0= )
+       postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+       tiff? ( media-libs/tiff:0 )
+       zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+       dev-util/gdbus-codegen
+       test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+       default
+       [[ "${PV}" == "9999" ]] && eautoreconf
+
+       # Bug #626800
+       append-cxxflags -std=c++11
+}
+
+src_configure() {
+       local myeconfargs=(
+               --enable-imagefilters
+               --localstatedir="${EPREFIX}"/var
+               --with-browseremoteprotocols=DNSSD,CUPS
+               --with-cups-rundir="${EPREFIX}"/run/cups
+               --with-fontdir="fonts/conf.avail"
+               --with-pdftops=pdftops
+               --with-rcdir=no
+               --without-php
+               $(use_enable dbus)
+               $(use_enable foomatic)
+               $(use_enable ipp_autosetup auto-setup-driverless)
+               $(use_enable ldap)
+               $(use_enable pclm)
+               $(use_enable pdf mutool)
+               $(use_enable postscript ghostscript)
+               $(use_enable postscript ijs)
+               $(use_enable static-libs static)
+               $(use_enable zeroconf avahi)
+               $(use_with jpeg)
+               $(use_with png)
+               $(use_with tiff)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_configure
+               perl-module_src_compile
+               popd > /dev/null
+       fi
+}
+
+src_install() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_install
+               perl_delete_localpod
+               popd > /dev/null
+       fi
+
+       if use postscript; then
+               # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+               dosym gstoraster /usr/libexec/cups/filter/pstoraster
+               dosym gstopxl /usr/libexec/cups/filter/pstopxl
+       fi
+
+       find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+       cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+       if ! use zeroconf ; then
+               sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+               sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+       fi
+
+       doinitd "${T}"/cups-browsed
+       systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+src_test() {
+       emake check
+}
+
+pkg_postinst() {
+       if ! use foomatic ; then
+               ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+               ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+       fi
+}