dev-python/pyhamcrest: Drop 1.9.0 (r0)
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 22 Feb 2020 16:55:49 +0000 (17:55 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 22 Feb 2020 20:22:18 +0000 (21:22 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/pyhamcrest/Manifest
dev-python/pyhamcrest/pyhamcrest-1.9.0.ebuild [deleted file]

index 2b62afa078cecb81157af7aa49728586d8f7c731..d968610eb0d6a17117e3a440cd2c19e2cb87d34c 100644 (file)
@@ -1,2 +1 @@
 DIST PyHamcrest-1.9.0.gh.tar.gz 57650 BLAKE2B c497688f03ec3b072d8ab076fc096a442d5cbbd94493eae57779879ccb6f281477aeeb7f7a67e539442010e60194f9f04a6deddd1d2267e9743742b45433f124 SHA512 3a878637ed5138365416c170871a63640f089047b723c7ec8db893dd716c0b1cdad16a98584700405693b954af7d4868a8543d1a3fc58ded22b493c8c61661b4
-DIST PyHamcrest-1.9.0.tar.gz 376623 BLAKE2B 808c74aa4dff89467c126cbc0e18029a9504cb27bbf03662a90666f85c76d7d7617260f50d35acde3a8e9e437b846589423cbb3697f8ceb86d0b5b838c586ebd SHA512 3b8393d0079b619b208ec7f06ed5133c4ff9d9dba050f818adf56347fc2225fd1c85d60f3dc262b7b9722061f0b8e4966180b6b96245a371e578d0d51633b4b0
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.9.0.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.9.0.ebuild
deleted file mode 100644 (file)
index 4bb3d7d..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-MY_PN="PyHamcrest"
-
-DESCRIPTION="Hamcrest framework for matcher objects"
-HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? (
-               >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
-               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-       )
-       test? (
-               >=dev-python/pytest-2.6[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-RESTRICT="test"
-# the pypi tarball is missing the tests
-# and the 1.9.0 tag is missing in GitHub
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx
-}
-
-python_test() {
-       py.test -v || die "Tests failed under ${EPYTHON}"
-       "${PYTHON}" tests/object_import.py || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       use examples && dodoc -r examples
-
-       distutils-r1_python_install_all
-}