dev-libs/engine_pkcs11: add libressl support
authorJulian Ospald <hasufell@gentoo.org>
Fri, 2 Oct 2015 18:36:53 +0000 (20:36 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Fri, 2 Oct 2015 18:37:21 +0000 (20:37 +0200)
dev-libs/engine_pkcs11/engine_pkcs11-0.1.8-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/engine_pkcs11/engine_pkcs11-0.1.8-r1.ebuild b/dev-libs/engine_pkcs11/engine_pkcs11-0.1.8-r1.ebuild
new file mode 100644 (file)
index 0000000..bf3f261
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="engine_pkcs11 is an implementation of an engine for OpenSSL"
+HOMEPAGE="http://www.opensc-project.org/engine_pkcs11"
+SRC_URI="http://www.opensc-project.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl"
+
+RDEPEND=">=dev-libs/libp11-0.2.5
+       !libressl? ( >=dev-libs/openssl-0.9.7d:0 )
+       libressl? ( dev-libs/libressl )
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+src_configure() {
+       econf \
+               --docdir="/usr/share/doc/${PF}" \
+               --htmldir="/usr/share/doc/${PF}/html" \
+               --disable-static --enable-shared \
+               --enable-doc
+}