Version bump, bug #147202. Dropped old versions.
authorTiziano Müller <dev-zero@gentoo.org>
Sat, 6 Jan 2007 23:43:39 +0000 (23:43 +0000)
committerTiziano Müller <dev-zero@gentoo.org>
Sat, 6 Jan 2007 23:43:39 +0000 (23:43 +0000)
Package-Manager: portage-2.1.2_rc4-r1

dev-python/ply/ChangeLog
dev-python/ply/files/digest-ply-2.2 [new file with mode: 0644]
dev-python/ply/ply-2.2.ebuild [new file with mode: 0644]

index 269d09959a644fa06d3ca5255d5f0822992aee51..a047445b0c4c9d14eb28f2487544fc88aff131b4 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/ply
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ChangeLog,v 1.6 2006/04/01 15:13:50 agriffis Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ChangeLog,v 1.7 2007/01/06 23:43:39 dev-zero Exp $
+
+*ply-2.2 (06 Jan 2007)
+
+  06 Jan 2007; Tiziano Müller <dev-zero@gentoo.org> -ply-1.5.ebuild,
+  -ply-1.6.ebuild, +ply-2.2.ebuild:
+  Version bump, bug #147202. Dropped old versions.
 
   01 Apr 2006; Aron Griffis <agriffis@gentoo.org> ply-1.6.ebuild:
   Mark 1.6 ~ia64
diff --git a/dev-python/ply/files/digest-ply-2.2 b/dev-python/ply/files/digest-ply-2.2
new file mode 100644 (file)
index 0000000..422140e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 7767a5e05e098c0ca76924d81f74c67e ply-2.2.tar.gz 142210
+RMD160 9fd6a1e1bece11977f5ba3e15a683b9f6211b353 ply-2.2.tar.gz 142210
+SHA256 2f96f64c1b8a30cbd5eb1c97d8ed6ea2fa0127d5a28ecd53ed4d969a6f315738 ply-2.2.tar.gz 142210
diff --git a/dev-python/ply/ply-2.2.ebuild b/dev-python/ply/ply-2.2.ebuild
new file mode 100644 (file)
index 0000000..98b3638
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ply-2.2.ebuild,v 1.1 2007/01/06 23:43:39 dev-zero Exp $
+
+inherit distutils
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+
+DESCRIPTION="Python Lex-Yacc library"
+SRC_URI="http://www.dabeaz.com/ply/${P}.tar.gz"
+HOMEPAGE="http://www.dabeaz.com/ply/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+       DOCS="ANNOUNCE CHANGES"
+       distutils_src_install
+       dohtml doc/*
+       if use examples ; then
+               insinto /usr/share/doc/${PF}
+               doins -r example
+       fi
+}
+
+src_test() {
+       cd test
+       python rununit.py || die "test failed"
+}