games-emulation/dosbox: Drop old 0.74_p20160629-r1
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 29 Dec 2018 12:12:18 +0000 (12:12 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 29 Dec 2018 12:15:54 +0000 (12:15 +0000)
Package-Manager: Portage-2.3.53, Repoman-2.3.12
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild [deleted file]

diff --git a/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild b/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild
deleted file mode 100644 (file)
index d7fd016..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools desktop flag-o-matic
-
-PATCH=3989
-GLIDE_PATCH=3722fc563b737d2d7933df6a771651c2154e6f7b
-
-DESCRIPTION="DOS emulator"
-HOMEPAGE="http://dosbox.sourceforge.net/"
-SRC_URI="mirror://gentoo/dosbox-code-0-${PATCH}-dosbox-trunk.zip
-       glide? ( https://raw.githubusercontent.com/voyageur/openglide/${GLIDE_PATCH}/platform/dosbox/dosbox_glide.diff -> dosbox_glide-${GLIDE_PATCH}.diff )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
-IUSE="alsa debug glide hardened opengl"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
-       glide? ( media-libs/openglide )
-       opengl? ( virtual/glu virtual/opengl )
-       debug? ( sys-libs/ncurses:0 )
-       media-libs/libpng:0
-       media-libs/libsdl[joystick,video,X]
-       media-libs/sdl-net
-       media-libs/sdl-sound"
-DEPEND="${RDEPEND}
-       app-arch/unzip"
-
-S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-0.74-gcc46.patch
-)
-
-src_prepare() {
-       use glide && eapply "${DISTDIR}"/dosbox_glide-${GLIDE_PATCH}.diff
-       default
-       eautoreconf
-}
-
-src_configure() {
-       use glide && append-cppflags -I"${EPREFIX}"/usr/include/openglide
-
-       econf \
-               $(use_enable alsa alsa-midi) \
-               $(use_enable !hardened dynamic-core) \
-               $(use_enable !hardened dynamic-x86) \
-               $(use_enable debug) \
-               $(use_enable opengl)
-}
-
-src_install() {
-       default
-       make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
-       doicon src/dosbox.ico
-}
-
-pkg_postinst() {
-       if use glide; then
-               elog "You have enabled unofficial Glide emulation. To use this, symlink"
-               elog "or copy ${EPREFIX}/usr/share/openglide/glide2x-dosbox.ovl to your game's"
-               elog "directory and add the following to your DOSBox configuration."
-               elog ""
-               elog "[glide]"
-               elog "glide=true"
-       fi
-}