don't fall out of the loop if update_copyright() didn't change
authormr_bones_ <mr_bones_@gentoo.org>
Sun, 28 Mar 2004 03:18:15 +0000 (03:18 -0000)
committermr_bones_ <mr_bones_@gentoo.org>
Sun, 28 Mar 2004 03:18:15 +0000 (03:18 -0000)
anything. Just go on to the next file.

svn path=/; revision=95

trunk/src/echangelog/ChangeLog
trunk/src/echangelog/echangelog

index e68bcf8ebedcf590d49b3a1ef8a0d66e52ec4ca9..9e3b0d0c8c314f939fef2fb76dff1109a36eebed 100644 (file)
@@ -1,3 +1,7 @@
+27 Mar 2004  Michael Sterrett <mr_bones_@gentoo.org>
+       * don't fall out of the loop if update_copyright() didn't change
+       anything. Just go on to the next file.
+
 21 Mar 2004 Aron Griffis <agriffis@gentoo.org>
        * Fix typo $0 -> 0
 
index ace14406204afb9921a5d1fb5bfd391dc1fcd4a1..6b6428de77f7c2efc2b8eeeb670698c197ee94f7 100644 (file)
@@ -221,7 +221,7 @@ for my $e (grep /\.ebuild$/, readdir D) {
 
        # Attempt the substitution and compare
        $netext = update_copyright($etext);
-       last if $netext eq $etext;
+       next if $netext eq $etext; # skip this file if no change.
 
        # Write the new ebuild
        open E, ">$e.new" or warn("Can't open $e.new\n"), next;