www-client/opera: Version 68.0.3618.125
authorJeroen Roovers <jer@gentoo.org>
Wed, 20 May 2020 05:57:21 +0000 (07:57 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 20 May 2020 06:01:31 +0000 (08:01 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
www-client/opera/Manifest
www-client/opera/opera-68.0.3618.125.ebuild [new file with mode: 0644]

index 35f0401918b9ae74f2dec5386437c0f1a0805f8a..3b9c7564bbda2c9dc8d8454b261fdc23b82f1ce9 100644 (file)
@@ -1 +1,2 @@
 DIST opera-stable_68.0.3618.104_amd64.deb 67438144 BLAKE2B 496a9c0c07d330878868ec4b4a3a69da6f90b6d019c867e36562182d1c1dc946d827614797d4e66bddc981809ae925bf1fe8f1f5871099d08d500ae9a1e666dc SHA512 32d5bcf6619bafc5bf92a898dd0d86d53c94e9f7e6fd265d82a989407fe1cb926d56af720c1ca11cbe7701000f8d61c1df076e865d1e241ad20839606ffe3430
+DIST opera-stable_68.0.3618.125_amd64.deb 67443988 BLAKE2B 47ea8888fa0084d46608cb3c5b8f298c919b4b34e120c9be5ace7cbbd173ec5c2ae28e475be4ac2d4c336b17eca66717a795fe96995127f5cf0fa675ec26f4fe SHA512 695781c3b07b8e41eabe723b988eaaa3f1738839766a06ef65689e504babf491e635580a79611476bc4f2eb1344951ece4c59d9b0e78b124fced4d154b080f20
diff --git a/www-client/opera/opera-68.0.3618.125.ebuild b/www-client/opera/opera-68.0.3618.125.ebuild
new file mode 100644 (file)
index 0000000..58c0be8
--- /dev/null
@@ -0,0 +1,110 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CHROMIUM_LANGS="
+       be bg bn ca cs da de el en-GB en-US es-419 es fil fi fr-CA fr hi hr hu id
+       it ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+       zh-CN zh-TW
+
+"
+inherit chromium-2 multilib unpacker xdg-utils
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2014"
+SLOT="0"
+SRC_URI_BASE="
+       https://download1.operacdn.com/pub/
+       https://download2.operacdn.com/pub/
+       https://download3.operacdn.com/pub/
+       https://download4.operacdn.com/pub/
+"
+for uri in ${SRC_URI_BASE}; do
+SRC_URI+="
+       "${uri}${PN}/desktop/${PV}/linux/${PN}-stable_${PV}_amd64.deb"
+"
+done
+KEYWORDS="~amd64"
+
+RDEPEND="
+       dev-libs/expat
+       dev-libs/glib:2
+       dev-libs/nspr
+       dev-libs/nss
+       media-libs/alsa-lib
+       media-libs/fontconfig
+       media-libs/freetype
+       net-misc/curl
+       net-print/cups
+       sys-apps/dbus
+       x11-libs/cairo
+       x11-libs/gdk-pixbuf
+       x11-libs/gtk+:3
+       x11-libs/libX11
+       x11-libs/libXScrnSaver
+       x11-libs/libXcomposite
+       x11-libs/libXcursor
+       x11-libs/libXdamage
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXi
+       x11-libs/libXrandr
+       x11-libs/libXrender
+       x11-libs/libXtst
+       x11-libs/libnotify
+       x11-libs/pango[X]
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+
+src_unpack() {
+       unpack_deb ${A}
+}
+
+src_prepare() {
+       default
+
+       OPERA_HOME="usr/$(get_libdir)/${PN}"
+
+       case ${ARCH} in
+               amd64)
+                       mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
+                       rm -r usr/lib || die
+                       ;;
+       esac
+
+       rm usr/bin/${PN} || die
+
+       rm usr/share/doc/${PN}-stable/copyright || die
+       mv usr/share/doc/${PN}-stable usr/share/doc/${PF} || die
+       gunzip usr/share/doc/${PF}/changelog.gz || die
+
+       pushd "${OPERA_HOME}"/localization > /dev/null || die
+       chromium_remove_language_paks
+       popd > /dev/null || die
+
+       sed -i \
+               -e 's|^TargetEnvironment|X-&|g' \
+               usr/share/applications/${PN}.desktop || die
+}
+
+src_install() {
+       rm "${OPERA_HOME}"/${PN}_autoupdate || die
+       mv * "${D}" || die
+       dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
+       fperms 4711 /"${OPERA_HOME}"/opera_sandbox
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}