app-emulation/libvirt: Rebase fix_paths_in_libvirt-guests_sh.patch
authorMichal Privoznik <mprivozn@redhat.com>
Fri, 31 Jan 2020 10:21:41 +0000 (11:21 +0100)
committerMatthias Maier <tamiko@gentoo.org>
Thu, 6 Feb 2020 15:45:54 +0000 (09:45 -0600)
Strictly speaking, this is not needed. But the upstream version
of the libvirt-guests.sh file has changed a bit so patch needs to
do some offsetting when applying the patch. Avoid that by
rebasing the patch onto current upstream.

Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/libvirt/files/libvirt-6.0.0-fix_paths_in_libvirt-guests_sh.patch [new file with mode: 0644]
app-emulation/libvirt/libvirt-9999.ebuild

diff --git a/app-emulation/libvirt/files/libvirt-6.0.0-fix_paths_in_libvirt-guests_sh.patch b/app-emulation/libvirt/files/libvirt-6.0.0-fix_paths_in_libvirt-guests_sh.patch
new file mode 100644 (file)
index 0000000..bf7a328
--- /dev/null
@@ -0,0 +1,35 @@
+From e97700d867ffa949c97f8a635a76b9ce510e806f Mon Sep 17 00:00:00 2001
+Message-Id: <e97700d867ffa949c97f8a635a76b9ce510e806f.1580460243.git.mprivozn@redhat.com>
+In-Reply-To: <5965f20fe0275b324c9b84ab7f48dd7db0494495.1580460243.git.mprivozn@redhat.com>
+References: <5965f20fe0275b324c9b84ab7f48dd7db0494495.1580460243.git.mprivozn@redhat.com>
+From: Michal Privoznik <mprivozn@redhat.com>
+Date: Fri, 31 Jan 2020 09:42:14 +0100
+Subject: [PATCH 2/3] Fix paths in libvirt-guests.sh.in
+
+Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
+---
+ tools/libvirt-guests.sh.in | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tools/libvirt-guests.sh.in b/tools/libvirt-guests.sh.in
+index a881f6266e..79d38b3e9a 100644
+--- a/tools/libvirt-guests.sh.in
++++ b/tools/libvirt-guests.sh.in
+@@ -39,11 +39,11 @@ START_DELAY=0
+ BYPASS_CACHE=0
+ SYNC_TIME=0
+-test -f "$sysconfdir"/sysconfig/libvirt-guests &&
+-    . "$sysconfdir"/sysconfig/libvirt-guests
++test -f "$sysconfdir"/libvirt/libvirt-guests.conf &&
++    . "$sysconfdir"/libvirt/libvirt-guests.conf
+ LISTFILE="$localstatedir"/lib/libvirt/libvirt-guests
+-VAR_SUBSYS_LIBVIRT_GUESTS="$localstatedir"/lock/subsys/libvirt-guests
++VAR_SUBSYS_LIBVIRT_GUESTS="$localstatedir"/lock/libvirt-guests
+ RETVAL=0
+-- 
+2.24.1
+
index 2d7662034fdc2a225813e5602faa2bc158f69a92..f26794bd40bbaaf5898277b82e446d4fdf4705e0 100644 (file)
@@ -124,8 +124,8 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
 PATCHES=(
-       "${FILESDIR}"/${PN}-1.2.16-fix_paths_in_libvirt-guests_sh.patch
        "${FILESDIR}"/${PN}-6.0.0-do-not-use-sysconf.patch
+       "${FILESDIR}"/${PN}-6.0.0-fix_paths_in_libvirt-guests_sh.patch
 )
 
 pkg_setup() {